summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2019-12-20 16:16:55 -0700
committerTim Harder <radhermit@gentoo.org>2019-12-20 16:37:51 -0700
commit7ec0aef3c64715ac39a3689eab635542ab949ce0 (patch)
tree7ee37d3864d4a20e0a8b194c8dba73b0244bedb8 /dev-python/snakeoil/snakeoil-0.8.5.ebuild
parentapp-i18n/anthy: Refer to app-editors/emacs in metadata.xml. (diff)
downloadgentoo-7ec0aef3c64715ac39a3689eab635542ab949ce0.tar.gz
gentoo-7ec0aef3c64715ac39a3689eab635542ab949ce0.tar.bz2
gentoo-7ec0aef3c64715ac39a3689eab635542ab949ce0.zip
dev-python/snakeoil: version bump to 0.8.5
Signed-off-by: Tim Harder <radhermit@gentoo.org>
Diffstat (limited to 'dev-python/snakeoil/snakeoil-0.8.5.ebuild')
-rw-r--r--dev-python/snakeoil/snakeoil-0.8.5.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/snakeoil/snakeoil-0.8.5.ebuild b/dev-python/snakeoil/snakeoil-0.8.5.ebuild
new file mode 100644
index 000000000000..e073443aa4a6
--- /dev/null
+++ b/dev-python/snakeoil/snakeoil-0.8.5.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python3_{6,7,8} )
+PYTHON_REQ_USE="threads(+)"
+inherit distutils-r1
+
+if [[ ${PV} == *9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/pkgcore/snakeoil.git"
+ inherit git-r3
+else
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sh ~sparc ~x86"
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+fi
+
+DESCRIPTION="misc common functionality and useful optimizations"
+HOMEPAGE="https://github.com/pkgcore/snakeoil"
+
+LICENSE="BSD BSD-2 MIT"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )
+"
+[[ ${PV} == 9999 ]] && DEPEND+=" dev-python/cython[${PYTHON_USEDEP}]"
+
+python_test() {
+ esetup.py test
+}