summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-06-27 04:50:26 +0200
committerMichał Górny <mgorny@gentoo.org>2023-06-27 05:54:40 +0200
commit82b364736436291f0aa58393dbb9f23c59e90e17 (patch)
treec42adfecddcc09386cb131b9de28094200686b54 /dev-python/sphinx-autodoc-typehints/sphinx-autodoc-typehints-1.23.3.ebuild
parentdev-python/pip-run: Bump to 12.1.0 (diff)
downloadgentoo-82b364736436291f0aa58393dbb9f23c59e90e17.tar.gz
gentoo-82b364736436291f0aa58393dbb9f23c59e90e17.tar.bz2
gentoo-82b364736436291f0aa58393dbb9f23c59e90e17.zip
dev-python/sphinx-autodoc-typehints: Bump to 1.23.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/sphinx-autodoc-typehints/sphinx-autodoc-typehints-1.23.3.ebuild')
-rw-r--r--dev-python/sphinx-autodoc-typehints/sphinx-autodoc-typehints-1.23.3.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/sphinx-autodoc-typehints/sphinx-autodoc-typehints-1.23.3.ebuild b/dev-python/sphinx-autodoc-typehints/sphinx-autodoc-typehints-1.23.3.ebuild
new file mode 100644
index 000000000000..c12ff85ed759
--- /dev/null
+++ b/dev-python/sphinx-autodoc-typehints/sphinx-autodoc-typehints-1.23.3.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Type hints support for the Sphinx autodoc extension"
+HOMEPAGE="
+ https://github.com/tox-dev/sphinx-autodoc-typehints/
+ https://pypi.org/project/sphinx-autodoc-typehints/
+"
+
+LICENSE="MIT"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+SLOT="0"
+
+RDEPEND="
+ >=dev-python/sphinx-5.3[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/hatch-vcs[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/nptyping-2.5[${PYTHON_USEDEP}]
+ >=dev-python/sphobjinv-2.3.1[${PYTHON_USEDEP}]
+ >=dev-python/typing-extensions-4.5[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # this package is addicted to Internet
+ tests/test_sphinx_autodoc_typehints.py::test_format_annotation
+)