summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-06-03 23:48:46 +0200
committerMichał Górny <mgorny@gentoo.org>2021-06-04 00:01:12 +0200
commit31c59c563c8badce61527e6958fa089ee240a81a (patch)
treeef0fbedb5c6a9cd58d7d0f9ad82b29f73cc6704a /dev-python/sphinx-panels/sphinx-panels-0.6.0.ebuild
parentdev-python/cfn-python-lint: Bump to 0.50.0 (diff)
downloadgentoo-31c59c563c8badce61527e6958fa089ee240a81a.tar.gz
gentoo-31c59c563c8badce61527e6958fa089ee240a81a.tar.bz2
gentoo-31c59c563c8badce61527e6958fa089ee240a81a.zip
dev-python/sphinx-panels: Bump to 0.6.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/sphinx-panels/sphinx-panels-0.6.0.ebuild')
-rw-r--r--dev-python/sphinx-panels/sphinx-panels-0.6.0.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/sphinx-panels/sphinx-panels-0.6.0.ebuild b/dev-python/sphinx-panels/sphinx-panels-0.6.0.ebuild
new file mode 100644
index 000000000000..3476ddafa385
--- /dev/null
+++ b/dev-python/sphinx-panels/sphinx-panels-0.6.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="A sphinx extension for creating panels in a grid layout"
+HOMEPAGE="https://github.com/executablebooks/sphinx-panels"
+SRC_URI="https://github.com/executablebooks/sphinx-panels/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+"
+
+BDEPEND="test? ( dev-python/pytest-regressions[${PYTHON_USEDEP}] )"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs dev-python/sphinx_rtd_theme