summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <patrick.mclean@sony.com>2020-05-06 17:16:10 -0700
committerPatrick McLean <chutzpah@gentoo.org>2020-05-06 17:16:25 -0700
commitb8ac5bbac1921cd193bd65b4af23c5b1953ce9b8 (patch)
tree98edebad21a3ee94554cedc9b580585a75d6de17 /dev-python/sphinxcontrib-httpexample/sphinxcontrib-httpexample-0.10.3.ebuild
parentdev-python/snapshottest: New package (diff)
downloadgentoo-b8ac5bbac1921cd193bd65b4af23c5b1953ce9b8.tar.gz
gentoo-b8ac5bbac1921cd193bd65b4af23c5b1953ce9b8.tar.bz2
gentoo-b8ac5bbac1921cd193bd65b4af23c5b1953ce9b8.zip
dev-python/sphinxcontrib-httpexample: New package
Copyright: Sony Interactive Entertainment Inc. Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'dev-python/sphinxcontrib-httpexample/sphinxcontrib-httpexample-0.10.3.ebuild')
-rw-r--r--dev-python/sphinxcontrib-httpexample/sphinxcontrib-httpexample-0.10.3.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/sphinxcontrib-httpexample/sphinxcontrib-httpexample-0.10.3.ebuild b/dev-python/sphinxcontrib-httpexample/sphinxcontrib-httpexample-0.10.3.ebuild
new file mode 100644
index 000000000000..62cfbf4fe443
--- /dev/null
+++ b/dev-python/sphinxcontrib-httpexample/sphinxcontrib-httpexample-0.10.3.ebuild
@@ -0,0 +1,44 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+inherit distutils-r1
+
+DESCRIPTION="Adds example directive for sphinx-contrib httpdomain"
+HOMEPAGE="https://github.com/collective/sphinxcontrib-httpexample"
+SRC_URI="https://github.com/collective/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-python/astunparse[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/namespace-sphinxcontrib[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/sphinxcontrib-httpdomain[${PYTHON_USEDEP}]
+"
+BDEPEND="${RDEPEND}
+ test? (
+ dev-python/snapshottest[${PYTHON_USEDEP}]
+ dev-python/sphinx_rtd_theme[${PYTHON_USEDEP}]
+ dev-python/sphinx-testing[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ sed -e "s:pytest-runner::" -i setup.cfg || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ distutils_install_for_testing
+ pytest -vv || die "tests fail with ${EPYTHON}"
+}