summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-06-23 07:09:32 +0200
committerMichał Górny <mgorny@gentoo.org>2020-06-23 08:03:49 +0200
commit55b1cb9ed79e4b4c3821bfa4846695ce8178a112 (patch)
tree813f7d4d9ac95c6ffc1cebacb39a48b24f49275e /dev-python/sphinxcontrib-spelling/sphinxcontrib-spelling-5.1.2.ebuild
parentdev-python/qtconsole: Bump to 4.7.5 (diff)
downloadgentoo-55b1cb9ed79e4b4c3821bfa4846695ce8178a112.tar.gz
gentoo-55b1cb9ed79e4b4c3821bfa4846695ce8178a112.tar.bz2
gentoo-55b1cb9ed79e4b4c3821bfa4846695ce8178a112.zip
dev-python/sphinxcontrib-spelling: Bump to 5.1.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/sphinxcontrib-spelling/sphinxcontrib-spelling-5.1.2.ebuild')
-rw-r--r--dev-python/sphinxcontrib-spelling/sphinxcontrib-spelling-5.1.2.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/sphinxcontrib-spelling/sphinxcontrib-spelling-5.1.2.ebuild b/dev-python/sphinxcontrib-spelling/sphinxcontrib-spelling-5.1.2.ebuild
new file mode 100644
index 000000000000..5b51077280e2
--- /dev/null
+++ b/dev-python/sphinxcontrib-spelling/sphinxcontrib-spelling-5.1.2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Sphinx spelling extension"
+HOMEPAGE="https://github.com/sphinx-contrib/spelling"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ dev-python/pbr[${PYTHON_USEDEP}]
+ dev-python/pyenchant[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ app-dicts/myspell-en
+ >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
+ dev-python/testtools[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs/source --no-autodoc
+distutils_enable_tests unittest
+
+RDEPEND+="
+ dev-python/namespace-sphinxcontrib[${PYTHON_USEDEP}]
+"
+
+python_install_all() {
+ distutils-r1_python_install_all
+ find "${ED}" -name '*.pth' -delete || die
+}