summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/stomper
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/stomper')
-rw-r--r--dev-python/stomper/Manifest1
-rw-r--r--dev-python/stomper/metadata.xml8
-rw-r--r--dev-python/stomper/stomper-0.3.0.ebuild36
3 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/stomper/Manifest b/dev-python/stomper/Manifest
new file mode 100644
index 000000000000..edb32d6fb2eb
--- /dev/null
+++ b/dev-python/stomper/Manifest
@@ -0,0 +1 @@
+DIST stomper-0.3.0.tar.gz 21051 SHA256 ceaacc016c0e8e98c3d3155f22069d18d403637d57492d9cf678813e27c9ecb0 SHA512 ba6feef44bb33a9b63f789043b131a314b903fda847dbb3ad909614a2a6b2b39f2d98dcd5bf19b070f4de9cec9dbce9cd79eb135911f16c1e8dc6d5f52158516 WHIRLPOOL 002bc793f6451ebcea03a1345930ba72df4e34aab288031371ba708daf06e58cb556c333f8c4fc640d129c2754171106679c28f983ceada4c5159208b6c895ff
diff --git a/dev-python/stomper/metadata.xml b/dev-python/stomper/metadata.xml
new file mode 100644
index 000000000000..98087bc50e6b
--- /dev/null
+++ b/dev-python/stomper/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <upstream>
+ <remote-id type="pypi">stomper</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/stomper/stomper-0.3.0.ebuild b/dev-python/stomper/stomper-0.3.0.ebuild
new file mode 100644
index 000000000000..e123d4fb6048
--- /dev/null
+++ b/dev-python/stomper/stomper-0.3.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+# Supports only py2 pypy
+PYTHON_COMPAT=( python2_7 pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Transport neutral client implementation of the STOMP protocol"
+HOMEPAGE="http://pypi.python.org/pypi/stomper"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha amd64 ~ppc ~ppc64 ~sparc x86"
+IUSE="examples"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND=""
+
+python_prepare_all() {
+ mv lib/${PN}/examples . || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ esetup.py test
+}
+
+python_install_all() {
+ use examples && local EXAMPLES=( examples/. )
+
+ distutils-r1_python_install_all
+}