summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/stomper')
-rw-r--r--dev-python/stomper/Manifest1
-rw-r--r--dev-python/stomper/metadata.xml8
-rw-r--r--dev-python/stomper/stomper-0.3.0.ebuild36
3 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/stomper/Manifest b/dev-python/stomper/Manifest
new file mode 100644
index 000000000000..edb32d6fb2eb
--- /dev/null
+++ b/dev-python/stomper/Manifest
@@ -0,0 +1 @@
+DIST stomper-0.3.0.tar.gz 21051 SHA256 ceaacc016c0e8e98c3d3155f22069d18d403637d57492d9cf678813e27c9ecb0 SHA512 ba6feef44bb33a9b63f789043b131a314b903fda847dbb3ad909614a2a6b2b39f2d98dcd5bf19b070f4de9cec9dbce9cd79eb135911f16c1e8dc6d5f52158516 WHIRLPOOL 002bc793f6451ebcea03a1345930ba72df4e34aab288031371ba708daf06e58cb556c333f8c4fc640d129c2754171106679c28f983ceada4c5159208b6c895ff
diff --git a/dev-python/stomper/metadata.xml b/dev-python/stomper/metadata.xml
new file mode 100644
index 000000000000..98087bc50e6b
--- /dev/null
+++ b/dev-python/stomper/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <upstream>
+ <remote-id type="pypi">stomper</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/stomper/stomper-0.3.0.ebuild b/dev-python/stomper/stomper-0.3.0.ebuild
new file mode 100644
index 000000000000..e123d4fb6048
--- /dev/null
+++ b/dev-python/stomper/stomper-0.3.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+# Supports only py2 pypy
+PYTHON_COMPAT=( python2_7 pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Transport neutral client implementation of the STOMP protocol"
+HOMEPAGE="http://pypi.python.org/pypi/stomper"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha amd64 ~ppc ~ppc64 ~sparc x86"
+IUSE="examples"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND=""
+
+python_prepare_all() {
+ mv lib/${PN}/examples . || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ esetup.py test
+}
+
+python_install_all() {
+ use examples && local EXAMPLES=( examples/. )
+
+ distutils-r1_python_install_all
+}