summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <patrick.mclean@sony.com>2019-11-20 13:53:32 -0800
committerPatrick McLean <chutzpah@gentoo.org>2019-11-20 13:53:57 -0800
commitabdbe7ce4786e9cd57da0ab3964ca2f7b7dfc450 (patch)
treedba3fd6d087b7423899791787764e516fd507b53 /dev-python/toml/toml-0.10.0-r1.ebuild
parentdev-qt/qtgui: Fix build with -xcb and -no-libinput (diff)
downloadgentoo-abdbe7ce4786e9cd57da0ab3964ca2f7b7dfc450.tar.gz
gentoo-abdbe7ce4786e9cd57da0ab3964ca2f7b7dfc450.tar.bz2
gentoo-abdbe7ce4786e9cd57da0ab3964ca2f7b7dfc450.zip
dev-python/toml: Revbump, enable tests, add py38
Copyright: Sony Interactive Entertainment Inc. Package-Manager: Portage-2.3.79, Repoman-2.3.18 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'dev-python/toml/toml-0.10.0-r1.ebuild')
-rw-r--r--dev-python/toml/toml-0.10.0-r1.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/toml/toml-0.10.0-r1.ebuild b/dev-python/toml/toml-0.10.0-r1.ebuild
new file mode 100644
index 000000000000..c0d855b0f8b4
--- /dev/null
+++ b/dev-python/toml/toml-0.10.0-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_{5,6,7,8}} pypy{,3} )
+
+inherit distutils-r1
+
+TOML_TEST_VER="39bb76d631ba103a94b377aaf52c979456677fb1"
+
+DESCRIPTION="Python library for handling TOML files"
+HOMEPAGE="https://github.com/uiri/toml"
+SRC_URI="https://github.com/uiri/${PN}/archive/${PV}.tar.gz -> ${P}-1.tar.gz
+ test? ( https://github.com/BurntSushi/toml-test/archive/${TOML_TEST_VER}.tar.gz -> toml-test-${TOML_TEST_VER}.tar.gz )"
+IUSE="test"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm64 ~hppa ~ia64 ~sparc ~x86"
+
+# peculiar testing depending on https://github.com/BurntSushi/toml-test. Not
+# particularly worth the trouble.
+#RESTRICT="test"
+
+BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( $(python_gen_cond_dep 'dev-python/numpy[${PYTHON_USEDEP}]' 'python3*') )"
+
+PATCHES=(
+ "${FILESDIR}/toml-0.10.0-depricationwarning.patch"
+)
+
+DOCS=( README.rst )
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ if use test; then
+ mv "${WORKDIR}/toml-test-${TOML_TEST_VER#v}" "${S}/toml-test" || die
+ fi
+
+ distutils-r1_python_prepare_all
+}