summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2015-08-29 13:32:24 -0400
committerTim Harder <radhermit@gentoo.org>2015-08-29 13:43:45 -0400
commita0f454fa3e00e1fe3f7333f4534305ff600de99b (patch)
tree84475a1b921a97d7b199ab9b2e41cc61d458a016 /dev-python/trollius/trollius-2.0.ebuild
parentsci-libs/rtabmap: Bump to 0.10.5 and update live ebuild. (diff)
downloadgentoo-a0f454fa3e00e1fe3f7333f4534305ff600de99b.tar.gz
gentoo-a0f454fa3e00e1fe3f7333f4534305ff600de99b.tar.bz2
gentoo-a0f454fa3e00e1fe3f7333f4534305ff600de99b.zip
dev-python/trollius: version bump to 2.0
Diffstat (limited to 'dev-python/trollius/trollius-2.0.ebuild')
-rw-r--r--dev-python/trollius/trollius-2.0.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/trollius/trollius-2.0.ebuild b/dev-python/trollius/trollius-2.0.ebuild
new file mode 100644
index 000000000000..b15094c7a12c
--- /dev/null
+++ b/dev-python/trollius/trollius-2.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+inherit distutils-r1
+
+DESCRIPTION="A port of the Tulip project (asyncio module, PEP3156)"
+HOMEPAGE="https://github.com/haypo/trollius https://pypi.python.org/pypi/trollius/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+
+RDEPEND="virtual/python-futures[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ "${PYTHON}" runtests.py || die "Testing failed under ${EPYTHON}"
+}