summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolic <jakov.smolic@sartura.hr>2020-11-18 19:57:43 +0100
committerDavid Seifert <soap@gentoo.org>2020-11-18 19:57:43 +0100
commitc8eb6465a3eeab05296a481a2cb18c61bc57ed68 (patch)
tree84fa4ff8e5dd5052333cfe91bf215c4ed59e92c5 /dev-python/ubelt/ubelt-0.9.1.ebuild
parentdev-python/xdoctest: drop old (diff)
downloadgentoo-c8eb6465a3eeab05296a481a2cb18c61bc57ed68.tar.gz
gentoo-c8eb6465a3eeab05296a481a2cb18c61bc57ed68.tar.bz2
gentoo-c8eb6465a3eeab05296a481a2cb18c61bc57ed68.zip
dev-python/ubelt: bump to 0.9.1, add python3_9
Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Jakov Smolic <jakov.smolic@sartura.hr> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'dev-python/ubelt/ubelt-0.9.1.ebuild')
-rw-r--r--dev-python/ubelt/ubelt-0.9.1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/ubelt/ubelt-0.9.1.ebuild b/dev-python/ubelt/ubelt-0.9.1.ebuild
new file mode 100644
index 000000000000..0801d0bd427d
--- /dev/null
+++ b/dev-python/ubelt/ubelt-0.9.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="A stdlib like feel, and extra batteries. Hashing, Caching, Timing, Progress"
+HOMEPAGE="https://github.com/Erotemic/ubelt"
+SRC_URI="https://github.com/Erotemic/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0"
+LICENSE="Apache-2.0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]
+ dev-python/ordered-set[${PYTHON_USEDEP}]"
+
+DEPEND="test? ( dev-python/xdoctest[${PYTHON_USEDEP}] )"
+
+distutils_enable_tests pytest
+
+python_test() {
+ pytest -vv tests || die "Tests fail with ${EPYTHON}"
+}