summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-03-17 17:19:39 +0100
committerMichał Górny <mgorny@gentoo.org>2024-03-17 17:24:41 +0100
commitcd15ab208a6a551069ec014a264c65aa94c04562 (patch)
treeeb17b85cdbd8d80025c4324da37a62eb0b941b17 /dev-python/x-wr-timezone/x-wr-timezone-0.0.7.ebuild
parentdev-python/recurring-ical-events: Bump to 2.1.3 (diff)
downloadgentoo-cd15ab208a6a551069ec014a264c65aa94c04562.tar.gz
gentoo-cd15ab208a6a551069ec014a264c65aa94c04562.tar.bz2
gentoo-cd15ab208a6a551069ec014a264c65aa94c04562.zip
dev-python/x-wr-timezone: Bump to 0.0.7
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/x-wr-timezone/x-wr-timezone-0.0.7.ebuild')
-rw-r--r--dev-python/x-wr-timezone/x-wr-timezone-0.0.7.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/x-wr-timezone/x-wr-timezone-0.0.7.ebuild b/dev-python/x-wr-timezone/x-wr-timezone-0.0.7.ebuild
new file mode 100644
index 000000000000..bdc5e6f792b8
--- /dev/null
+++ b/dev-python/x-wr-timezone/x-wr-timezone-0.0.7.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Convert calendars using X-WR-TIMEZONE to standard ones"
+HOMEPAGE="
+ https://github.com/niccokunzmann/x-wr-timezone/
+ https://pypi.org/project/x-wr-timezone/
+"
+SRC_URI="
+ https://github.com/niccokunzmann/x-wr-timezone/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="LGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/icalendar-5.0.11[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_IGNORE=(
+ test/test_readme.py
+)