summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-06-14 09:45:46 +0200
committerMichał Górny <mgorny@gentoo.org>2020-06-14 10:29:27 +0200
commit2f4243913db8284289b0e247e207818d06f61c14 (patch)
tree7ef98dbfe151b9389cc264e6583db430a6b6172d /dev-python/zstandard/zstandard-0.14.0.ebuild
parentdev-python/boto3: Bump to 1.14.2 (diff)
downloadgentoo-2f4243913db8284289b0e247e207818d06f61c14.tar.gz
gentoo-2f4243913db8284289b0e247e207818d06f61c14.tar.bz2
gentoo-2f4243913db8284289b0e247e207818d06f61c14.zip
dev-python/zstandard: Bump to 0.14.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/zstandard/zstandard-0.14.0.ebuild')
-rw-r--r--dev-python/zstandard/zstandard-0.14.0.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/zstandard/zstandard-0.14.0.ebuild b/dev-python/zstandard/zstandard-0.14.0.ebuild
new file mode 100644
index 000000000000..2f9ab74169ae
--- /dev/null
+++ b/dev-python/zstandard/zstandard-0.14.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_{6..9}} )
+
+inherit distutils-r1
+
+DESCRIPTION="Zstandard Bindings for Python"
+HOMEPAGE="https://pypi.org/project/zstandard/ https://github.com/indygreg/python-zstandard"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+RDEPEND=">=dev-python/cffi-1.14.0-r2:=[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? ( dev-python/hypothesis[${PYTHON_USEDEP}] )"
+
+distutils_enable_tests setup.py
+
+python_compile() {
+ local MAKEOPTS=-j1
+ distutils-r1_python_compile
+}