summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-12-14 08:42:28 +0100
committerMichał Górny <mgorny@gentoo.org>2021-12-14 11:21:26 +0100
commit086241ba9bb7429cdbb50b6a2d3dae0b9d49e715 (patch)
treec2be47ea547c3a4e3fa836a1805ef82a2e2d2a38 /dev-python
parentdev-python/pytest-timeout: Bump to 2.0.2 (diff)
downloadgentoo-086241ba9bb7429cdbb50b6a2d3dae0b9d49e715.tar.gz
gentoo-086241ba9bb7429cdbb50b6a2d3dae0b9d49e715.tar.bz2
gentoo-086241ba9bb7429cdbb50b6a2d3dae0b9d49e715.zip
dev-python/pylama: Bump to 8.3.5
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pylama/Manifest1
-rw-r--r--dev-python/pylama/pylama-8.3.5.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/pylama/Manifest b/dev-python/pylama/Manifest
index 24ec02ee8b54..111b62048ac5 100644
--- a/dev-python/pylama/Manifest
+++ b/dev-python/pylama/Manifest
@@ -2,3 +2,4 @@ DIST pylama-7.7.1.tar.gz 34740 BLAKE2B a4bd5aed40c2c4e7bdb9f9968030f0954f0309cff
DIST pylama-8.0.4.tar.gz 34064 BLAKE2B e6ec937b7716d8a64c19e71b370e557a30d04d908ed2d1859df380c381a7eea93956ec4b58ca779e6029119a017ffce268a5528424783b33e815827dacb79b5d SHA512 c2ad152cadfaed14a6035eb49361439b8f80c7c633b5e1b185dd5dad140a4148f6d4445928e08cb8e92b205739ef75df6d49c66e4ad3cd002512cc2a8aba859b
DIST pylama-8.0.6.tar.gz 34223 BLAKE2B 690a0a1197f6512e9511083aa079843f2ca99c9bdb5d74756531db79f7d39e8e0f60a0955b24bc7739edce0376eb79821a796978fb2365789a97628f03f240f8 SHA512 5bc75e5b2a0b141dbe2ca993d13833914980c735b84f3df766bf750909af1eeaba0d554845d8c09f0d8186ff48c8330d9ffa5b565a577ef6506f32672a2c9209
DIST pylama-8.3.3.tar.gz 36292 BLAKE2B e9ed2156c90af1ef33b8a3875dffbe6ee939e70b3a35e0bd9c6f29d5de6ef929e73cf7eda773f6693fdce96e763e81f336fc983a32f9cfa8d124441d5d34b060 SHA512 57db11480752a650dc2871bd8be139492cd5273c3770aefab160855d601e524a24754cf3b4e60973ce00072c1025749c7f9d9d39a5447ca27ab60979e743a72d
+DIST pylama-8.3.5.tar.gz 36117 BLAKE2B 6ae876b7e1e0dbfba08c9b7460cbab129b1b43f79a274c191fb7710966fac4b100b1e1c81ac3a440c33b9ed076fb3a60eb5d732f484fc7150c096a7207c3b4d4 SHA512 8be5aa0490ad7e08e6def974c9b8c83c457679dfbdb2b7c161c71fc3f5f68b7e40c96ee41a57d1a1b8689356e22a028aa22400c747c17aa520b5be3e219569e7
diff --git a/dev-python/pylama/pylama-8.3.5.ebuild b/dev-python/pylama/pylama-8.3.5.ebuild
new file mode 100644
index 000000000000..fab10b0885f6
--- /dev/null
+++ b/dev-python/pylama/pylama-8.3.5.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Code audit tool for python"
+HOMEPAGE="https://github.com/klen/pylama"
+SRC_URI="https://github.com/klen/pylama/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~mips ~x86"
+
+RDEPEND="
+ >=dev-python/mccabe-0.6.1[${PYTHON_USEDEP}]
+ >=dev-python/pycodestyle-2.8.0[${PYTHON_USEDEP}]
+ >=dev-python/pydocstyle-6.1.1[${PYTHON_USEDEP}]
+ >=dev-python/pyflakes-2.4.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/eradicate[${PYTHON_USEDEP}]
+ dev-python/mypy[${PYTHON_USEDEP}]
+ dev-python/pylint[${PYTHON_USEDEP}]
+ dev-python/radon[${PYTHON_USEDEP}]
+ dev-vcs/git
+ )
+"
+
+distutils_enable_sphinx docs
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # not packaged
+ tests/test_linters.py::test_quotes
+ tests/test_linters.py::test_vulture
+)