summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-12-14 08:38:48 +0100
committerMichał Górny <mgorny@gentoo.org>2021-12-14 11:21:25 +0100
commite5bdcd17f1ff1bd61d1d29ee7cd363aae92ef08c (patch)
treecfbdb77a16da47d1172cb57da4c596668b4a7751 /dev-python
parentdev-python/isodate: Bump to 0.6.1 (diff)
downloadgentoo-e5bdcd17f1ff1bd61d1d29ee7cd363aae92ef08c.tar.gz
gentoo-e5bdcd17f1ff1bd61d1d29ee7cd363aae92ef08c.tar.bz2
gentoo-e5bdcd17f1ff1bd61d1d29ee7cd363aae92ef08c.zip
dev-python/pytest-timeout: Bump to 2.0.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pytest-timeout/Manifest1
-rw-r--r--dev-python/pytest-timeout/pytest-timeout-2.0.2.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/pytest-timeout/Manifest b/dev-python/pytest-timeout/Manifest
index 3f2e83390f0f..34e22d134c82 100644
--- a/dev-python/pytest-timeout/Manifest
+++ b/dev-python/pytest-timeout/Manifest
@@ -1 +1,2 @@
DIST pytest-timeout-2.0.0.tar.gz 16210 BLAKE2B 8e3c0436147b6cc680540329daabd7269d301c95663599f7e9c64313bc3a45fde5cc5ea297d5b8c85f43d1a80c2db44b8e150877c3c7b29eef5e38426dfd4efc SHA512 96e9b545b4ac1e4a615863f69d190e0265e85f23dc12df51e9035b8e6bceff23279bb042eed83aa0ddd6d06b0e02a2dcc29ee352fd44cc86f0682fb328264645
+DIST pytest-timeout-2.0.2.tar.gz 16683 BLAKE2B bc6ee17832dfa5c3e5a35efc34bda630f1f1f7e7ece5a71d68110ab12c08566ee89c3b0f68967807967d17e2622ca1d2bce24baf51986ad8921fd55df091b376 SHA512 ee151a55f6323ae23ddd7e54e39e1c014de2aa2a142a0e3ba81c80b5d36435fc6c2809e383df8c49e62df70361a03dbe73e4d96d03798323fe7f1304a197f770
diff --git a/dev-python/pytest-timeout/pytest-timeout-2.0.2.ebuild b/dev-python/pytest-timeout/pytest-timeout-2.0.2.ebuild
new file mode 100644
index 000000000000..5be23064f839
--- /dev/null
+++ b/dev-python/pytest-timeout/pytest-timeout-2.0.2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="pytest plugin to abort hanging tests"
+HOMEPAGE="https://pypi.org/project/pytest-timeout/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+# do not rdepend on pytest, it won't be used without it anyway
+# pytest-cov used to test compatibility
+BDEPEND="
+ test? (
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ !hppa? (
+ dev-python/pytest-cov[${PYTHON_USEDEP}]
+ )
+ )"
+
+distutils_enable_tests --install pytest