summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSébastien Fabbro <bicatali@gentoo.org>2017-06-27 02:58:34 +0000
committerSébastien Fabbro <bicatali@gentoo.org>2017-06-28 04:00:07 +0000
commit13c8c18c88a44bae3e02562994d3bb43df0027cc (patch)
treecd92de642eb86ecfb2f28d96b4f39aa3bba6068e /dev-python
parentnet-misc/s3cmd: bump. (diff)
downloadgentoo-13c8c18c88a44bae3e02562994d3bb43df0027cc.tar.gz
gentoo-13c8c18c88a44bae3e02562994d3bb43df0027cc.tar.bz2
gentoo-13c8c18c88a44bae3e02562994d3bb43df0027cc.zip
dev-python/sortedcollections: version bump
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/sortedcollections/Manifest1
-rw-r--r--dev-python/sortedcollections/sortedcollections-0.5.3.ebuild25
2 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/sortedcollections/Manifest b/dev-python/sortedcollections/Manifest
index dd970ae26e43..59cc422643d8 100644
--- a/dev-python/sortedcollections/Manifest
+++ b/dev-python/sortedcollections/Manifest
@@ -1 +1,2 @@
DIST sortedcollections-0.4.2.tar.gz 111533 SHA256 8aefd6cf0bb0a89888f192859c3dbf997b906b33cd4ce175d568fb972cfdb489 SHA512 53a3c9228c13bf25faedd11058413269d26e51209a5f454851aae067679e64ca3897ab78632a620f1f88c8c6407c5b723974d3a6aa4185e7e12b166d55f6559a WHIRLPOOL 16196d2bf09baab0ff68ac7c7f74ce27f409d229cc414b9f62fb1319f5edcebd5e8244453956308c07d3d950fd23195f7606d6bef71e38152b745b0fec6cfd0d
+DIST sortedcollections-0.5.3.tar.gz 7021 SHA256 d56d6708e36aec959b08e64c3e5a0e01df518d6e6693d0f5b5c89529288edde6 SHA512 e0076017d1a97d7dc18b02bc4e3739c535ab001260be739fab2784cb58deac4323957fe21b4c679f55a790d864ca696695a603298709225b04eae740d859ab28 WHIRLPOOL ce3693115a2e694c8908c8a1ce9027b9adccf15e38ebad36c456265440174b77620d525d898d1a914626a0a698fc75280aca549e8c78d082f6888b6c3433173f
diff --git a/dev-python/sortedcollections/sortedcollections-0.5.3.ebuild b/dev-python/sortedcollections/sortedcollections-0.5.3.ebuild
new file mode 100644
index 000000000000..31c883ffaa6f
--- /dev/null
+++ b/dev-python/sortedcollections/sortedcollections-0.5.3.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python library to sort collections and containers"
+HOMEPAGE="http://www.grantjenks.com/docs/sortedcontainers/"
+SRC_URI="mirror://pypi/$(echo ${PN} | cut -c 1)/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="dev-python/sortedcontainers[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+python_test() {
+ py.test -v || die
+}