summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-12-29 09:39:42 +0100
committerMichał Górny <mgorny@gentoo.org>2020-12-29 12:45:51 +0100
commit189dceaff43004d6a9da3f6cd6c1e55b1aeaf034 (patch)
tree03c5ab58e0e917a4a84f30d9b8153fb141099dd3 /dev-python
parentdev-python/botocore: Bump to 1.19.44 (diff)
downloadgentoo-189dceaff43004d6a9da3f6cd6c1e55b1aeaf034.tar.gz
gentoo-189dceaff43004d6a9da3f6cd6c1e55b1aeaf034.tar.bz2
gentoo-189dceaff43004d6a9da3f6cd6c1e55b1aeaf034.zip
dev-python/boto3: Bump to 1.16.44
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/boto3/Manifest1
-rw-r--r--dev-python/boto3/boto3-1.16.44.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index ce626e3bedb4..c051a9dab57c 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -5,3 +5,4 @@ DIST boto3-1.16.40.tar.gz 342028 BLAKE2B 6728b658ee75b76d4885e43316a58508a856347
DIST boto3-1.16.41.tar.gz 342352 BLAKE2B 601384979c792a2e1871bd3837ca2a56e411d0f50ee2766bde33f8be1b0e1fa4078bd731b002008d98efc5ef6d2893ec3811238d45f1f6e22ba4904972aa960e SHA512 c80727d2788603db8d46e1ec9c766341a875b7768cfeb86425b784141c8854f314fcb2de1618203971eac3734f64b26523e268f4ca2039f513f9ea6a218ab8be
DIST boto3-1.16.42.tar.gz 342384 BLAKE2B c966fb6bb645bfa513b30bc72592eab404954c2816d4e2e533af8c0753941f07b8228201f17077d252086a2d2167ef31ba11abe6154500b125ee74a1e6d3218a SHA512 0316179c0acd1afe798c3b54bfc7cde5ac3082e6747228619a72b805ae3b2a56311cdcde54ca2afa49ee62c3554b986ff2986c60ba7b5cbdad570a329b6371fb
DIST boto3-1.16.43.tar.gz 342444 BLAKE2B 1a367fa252eab6738533c7bec2bc370dcc206f25c4290ea34632ef82a0e308aa4521af7bd2e9755782b3b66b438c528e67f55f7238183ffff2318bfb7361e924 SHA512 1cd757a2751e48b9075f99724a9980d882751542f5a7794a4cbddc46f82a1bbf00b8e0908e0cd2db16726636750d591aee26b00004a454c35d24ab79de9c80b9
+DIST boto3-1.16.44.tar.gz 342481 BLAKE2B c6241580998fe729cbb706c8d99a441fabae6199ed11d36559ba9f3d11b0ef2e41122d3cd7fb418d5e60de8cf698ccb0595c4534d708a8acaddfb752add7c886 SHA512 812b165dd28f41e126b0d728c25891adf974f641a470e0fd4270873af4499432579d77d612e2a0ad89d9c37de87ff1afdf09472445ea7aa3ebad4c9a157d5b16
diff --git a/dev-python/boto3/boto3-1.16.44.ebuild b/dev-python/boto3/boto3-1.16.44.ebuild
new file mode 100644
index 000000000000..ccc99e1c2415
--- /dev/null
+++ b/dev-python/boto3/boto3-1.16.44.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6..9} )
+DISTUTILS_USE_SETUPTOOLS=bdepend
+inherit distutils-r1
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="https://github.com/boto/boto3"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/boto3"
+ inherit git-r3
+ BOTOCORE_PV=${PV}
+else
+ SRC_URI="https://github.com/boto/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
+
+ # botocore is x.(y+3).z
+ BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 3)).$(ver_cut 3-)"
+fi
+
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.3.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests nose
+
+python_prepare_all() {
+ # don't lock versions to narrow ranges
+ sed -e '/botocore/ d' \
+ -e '/jmespath/ d' \
+ -e '/s3transfer/ d' \
+ -i setup.py || die
+
+ # prevent an infinite loop
+ rm tests/functional/docs/test_smoke.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ nosetests -v tests/unit/ tests/functional/ || die "test failed under ${EPYTHON}"
+}