summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-03-30 19:49:25 +0200
committerMichał Górny <mgorny@gentoo.org>2022-03-30 20:45:41 +0200
commit422119f321ea2c81348cef90941748fb34479ac8 (patch)
tree356ca4cdc4b0aa9f583716462c39cc4c61341cac /dev-python
parentdev-python/botocore: Bump to 1.24.29 (diff)
downloadgentoo-422119f321ea2c81348cef90941748fb34479ac8.tar.gz
gentoo-422119f321ea2c81348cef90941748fb34479ac8.tar.bz2
gentoo-422119f321ea2c81348cef90941748fb34479ac8.zip
dev-python/boto3: Bump to 1.21.29
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/boto3/Manifest1
-rw-r--r--dev-python/boto3/boto3-1.21.29.ebuild63
2 files changed, 64 insertions, 0 deletions
diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index 34e9f105039d..a65744d752a7 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -4,4 +4,5 @@ DIST boto3-1.21.25.tar.gz 482117 BLAKE2B 7f4823fa6045addb4b4ed01e83d1095e9f56dac
DIST boto3-1.21.26.tar.gz 482624 BLAKE2B 19f38b86eab6363ff86febc9f7623def010314a70e3d88c405bf641a4cd0b2de390fb69f5205c5df2e7d71c80a31989efbc64c442bd02d3d2a5efb7ee937596d SHA512 85848df7f5863df5ddc97be29f734bbdff54d195d5d1e465b35f3693b8196c03422b9a8024a2ecdaead40a4ddd1742c06e9d2e5b90fd4de28dffd6609f209dfb
DIST boto3-1.21.27.tar.gz 482968 BLAKE2B f8dbabe73377a861cf1d3d2e9388f7ba91f2047d8ce792b44a10693e5b0575924b3abbd8ec2b72d0c3b9a553bb088fc17dc4cd23b571f375db45737376931a46 SHA512 54bb43022ba12fc7b5c54872632cd46c07c6f167246917b5413cdd30de6c327bc625410cdfe62f4ff257ad7c42da762d2bcec5515367e214131259ddc69a9061
DIST boto3-1.21.28.tar.gz 483052 BLAKE2B 89afa5ff7d9b8c256b525ef2d67a17de45fda8b63a3640513d9a786b2bcd77c0b8a5a572deb4bf3fb264fcc9c317c510b27fd836cba958816514bc1ac32bc327 SHA512 af6a8d11371b3616b15a5bf996b165808590d0074ead1bb54ee1b7a8357cd076648700838aba84f7d370120981db36096a6060c8b00ea7bdd9a4da5cb5ddcb8c
+DIST boto3-1.21.29.tar.gz 483137 BLAKE2B fa753a52923d013a3c5b3981fb32614bc5cb7be1b7696d2b60df877b33814553c22eccaf8d66e4719922b4289181c2e8356a3b377b25e81c8bdf8496cd49d0a9 SHA512 6c916fce1097d226b865cebf2d8791bc40506d9dd5b2db49b61e038872fb2f51d9de727ab8c9da3accced2563e81314dbe87788af57d6366fb90c446d3b79555
DIST boto3-1.21.8.tar.gz 473069 BLAKE2B f08f76fb9c4e56e6ba5624c885973599505769d7f9eea6e20a06e1a641768b1f7b108fc7293282a55bf4c7d2b62eb34853f46b8c3ada9afb8fc25624daa60c12 SHA512 23ed88dcaefe3224db05959251befaae4f03859bf00daf649db1e838e5fb92e01a6da4bee8083366d804404aac358df19d7e4552d6aaf39f9c4b371ccc7f9088
diff --git a/dev-python/boto3/boto3-1.21.29.ebuild b/dev-python/boto3/boto3-1.21.29.ebuild
new file mode 100644
index 000000000000..6fcba460ab1d
--- /dev/null
+++ b/dev-python/boto3/boto3-1.21.29.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1 multiprocessing
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="https://github.com/boto/boto3"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/boto3"
+ inherit git-r3
+ BOTOCORE_PV=${PV}
+else
+ SRC_URI="https://github.com/boto/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+ # botocore is x.(y+3).z
+ BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 3)).$(ver_cut 3-)"
+fi
+
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.3.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # don't lock versions to narrow ranges
+ sed -e '/botocore/ d' \
+ -e '/jmespath/ d' \
+ -e '/s3transfer/ d' \
+ -i setup.py || die
+
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ epytest tests/{functional,unit} \
+ -n "$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")"
+}