summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-02-03 07:40:51 +0100
committerMichał Górny <mgorny@gentoo.org>2023-02-03 08:19:08 +0100
commit5006a5425972775cc4195c197ae3cf07e3d50ef7 (patch)
treee2c586cb73c288236a59bfc2cde71516e05cecdf /dev-python
parentdev-python/botocore: Bump to 1.29.63 (diff)
downloadgentoo-5006a5425972775cc4195c197ae3cf07e3d50ef7.tar.gz
gentoo-5006a5425972775cc4195c197ae3cf07e3d50ef7.tar.bz2
gentoo-5006a5425972775cc4195c197ae3cf07e3d50ef7.zip
dev-python/boto3: Bump to 1.26.63
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/boto3/Manifest1
-rw-r--r--dev-python/boto3/boto3-1.26.63.ebuild68
2 files changed, 69 insertions, 0 deletions
diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index 8190e5cf1a08..c81e302670ed 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -6,3 +6,4 @@ DIST boto3-1.26.59.gh.tar.gz 594565 BLAKE2B 90c5fe950da7fabc46a4c34e0a77997cfc64
DIST boto3-1.26.60.gh.tar.gz 595047 BLAKE2B ae920d1fd17e4ceb81c512f5d2af63e4b6c09d8a5382bc50656a8ade1bd490a28bc299d7beb9b3f2b271d1001dbad7f3f1a52177d0d6a09943aea5b351a805dc SHA512 372b3e1a5265448a1f7ed11e1d66f2d33f7b35a5b66203220470eefa93eb04cbcddf2f45809ee5d1d2d369bd75ae40dbd48580b6a30a5f43d97e6b04c6211cfa
DIST boto3-1.26.61.gh.tar.gz 596525 BLAKE2B 4d6e4548bc7f2ee57145341a107c6ebafd4fc47b13f10ddc142e974c8444365eb5242510994d9f8bb1d020b988ae08c25322d8a6e96184053ace65583c4f0375 SHA512 22f92510a959714a2128730cd618d602542a4c0f305a3560ff8b2acfb79a8bbab07d417bb10830c04d80406cfb31fa8c3765de3506ad7839efd403410c887836
DIST boto3-1.26.62.gh.tar.gz 597271 BLAKE2B ec5585060479da854567b8bf50271b083bd3bf4eec382db3391408a5b7b9c09d7ad67689b87643a1f411609624008a691935bbacaecf321bc39f9783a92349d2 SHA512 5209f6f9ae308df56d5dc8b15b6f4a6b083fd92ed365b715e9d22861d5ab9058ebf343e94e702830933d1eaee60f1566fed4e87b76585e52b1bab8ea92b3ccb2
+DIST boto3-1.26.63.gh.tar.gz 597618 BLAKE2B f48de0f51694efa0a4fa6afa25ad7475fb7e304cf9291d6dcd275d4dd64ee3f29665afd1fb64f5883513c4224e03240a8e225e41765409822d33e95078e1a9ac SHA512 5f781ce615202fa84e321982699877376b2cb3692cf52f2b157eea6800d160ccf6da38b3c545d62cbce029b59f492d5ef67a31d06dc33b6f6bffd1e1b40c5d85
diff --git a/dev-python/boto3/boto3-1.26.63.ebuild b/dev-python/boto3/boto3-1.26.63.ebuild
new file mode 100644
index 000000000000..9523f65d5fb9
--- /dev/null
+++ b/dev-python/boto3/boto3-1.26.63.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 multiprocessing
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="
+ https://github.com/boto/boto3/
+ https://pypi.org/project/boto3/
+"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/boto3"
+ inherit git-r3
+ BOTOCORE_PV=${PV}
+else
+ SRC_URI="
+ https://github.com/boto/boto3/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ "
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+ # botocore is x.(y+3).z
+ BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 3)).$(ver_cut 3-)"
+fi
+
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.6.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # don't lock versions to narrow ranges
+ sed -e '/botocore/ d' \
+ -e '/jmespath/ d' \
+ -e '/s3transfer/ d' \
+ -i setup.py || die
+
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ epytest tests/{functional,unit} -n "$(makeopts_jobs)"
+}