summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-12-19 18:10:01 +0100
committerMichał Górny <mgorny@gentoo.org>2023-12-19 18:25:58 +0100
commit59c9a6e38173b910cbbac0859ab5c96ca9103e2d (patch)
tree1908a63b2d3d93d603e5d5022b1d056a8388559d /dev-python
parentdev-python/readthedocs-sphinx-ext: Bump to 2.2.5 (diff)
downloadgentoo-59c9a6e38173b910cbbac0859ab5c96ca9103e2d.tar.gz
gentoo-59c9a6e38173b910cbbac0859ab5c96ca9103e2d.tar.bz2
gentoo-59c9a6e38173b910cbbac0859ab5c96ca9103e2d.zip
dev-python/zeroconf: Bump to 0.131.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/zeroconf/Manifest1
-rw-r--r--dev-python/zeroconf/zeroconf-0.131.0.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/dev-python/zeroconf/Manifest b/dev-python/zeroconf/Manifest
index fdf30715405d..f1f0a2f8d0b9 100644
--- a/dev-python/zeroconf/Manifest
+++ b/dev-python/zeroconf/Manifest
@@ -3,3 +3,4 @@ DIST zeroconf-0.128.0.tar.gz 161199 BLAKE2B 7526c6f4a242e7ab0035ea3f2b29b3b43bbb
DIST zeroconf-0.128.4.tar.gz 162384 BLAKE2B cd8b60d0f0bdf01835fc1bf3c9bc74311ea4cc353ba1e0825264e850d070c8cee3565ec9942d825c404406623c7e65851688b447afbe1bf9884da077993a77de SHA512 d0781c1c5752eda31806826475cee0e7032e4bae9612adf0f8b7dab21d15be2762fb37af17a34f93f2f5f27ee936fcf4d7e58ce1d9b42af3e8681d5e8eb326ee
DIST zeroconf-0.129.0.tar.gz 163756 BLAKE2B 13ac698352fd18d2025ed60d6906e7add6726a07c0e5e29f4fbf5bdd9f666a17d0401acbab70197182e7112e98e03eceb8a5d64f927a15f52b592b669615a4ad SHA512 51e6edf5474e8bfcd63c31b13abc5ef382c4eab1e4d41e2d4f454615e1cc09aab63dc13f29c1a1126d3ae131c6d8df762748f0c5bdf2149c968517a0a15fc0ff
DIST zeroconf-0.130.0.tar.gz 169034 BLAKE2B cda4002e07fcb784ab03208d25bbe4dbb3349df9473a78fca3032b5ed5bc882edcd35179f4721e3ae4f12880f464d9ef43ad03216aa272b58f034f929aabd06d SHA512 8f2ce4ae9f58a28c658253a2c17a85968d51e2483442d726849ad254e5250f1b4e83f106540e7562369d4bbdfa05fc470636cc4a4f913dc5b1c94ea03b726d74
+DIST zeroconf-0.131.0.tar.gz 169253 BLAKE2B 64247bdca5f8a226e73078b0395fa273649d3baea54fe52c350bf5117527e4290974843385f5b23568a6350bb41fa0af13a6999ef4e880fc42952dde21126296 SHA512 7b7f5494a589306c458dc4fedd940aab86918e9979d5b9f0a466d28b74795c83351f82fdf501a983e9df3e32a8be9a88af3486e79ade23ab73d889610331d89a
diff --git a/dev-python/zeroconf/zeroconf-0.131.0.ebuild b/dev-python/zeroconf/zeroconf-0.131.0.ebuild
new file mode 100644
index 000000000000..9cb88f18ecad
--- /dev/null
+++ b/dev-python/zeroconf/zeroconf-0.131.0.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Pure Python Multicast DNS Service Discovery Library (Bonjour/Avahi compatible)"
+HOMEPAGE="
+ https://github.com/python-zeroconf/python-zeroconf/
+ https://pypi.org/project/zeroconf/
+"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ >=dev-python/ifaddr-0.1.7[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/async-timeout-3.0.0[${PYTHON_USEDEP}]
+ ' 3.10)
+"
+# the build system uses custom build script that uses distutils to build
+# C extensions, sigh
+BDEPEND="
+ >=dev-python/cython-3.0.5[${PYTHON_USEDEP}]
+ >=dev-python/setuptools-65.6.3[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+export REQUIRE_CYTHON=1
+
+python_test() {
+ local -x SKIP_IPV6=1
+ local EPYTEST_DESELECT=(
+ # network
+ tests/test_core.py::Framework::test_close_multiple_times
+ tests/test_core.py::Framework::test_launch_and_close
+ tests/test_core.py::Framework::test_launch_and_close_context_manager
+
+ # fragile to timeouts (?)
+ tests/services/test_browser.py::test_service_browser_expire_callbacks
+ tests/utils/test_asyncio.py::test_run_coro_with_timeout
+ )
+
+ epytest -o addopts=
+}