summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sbraz@gentoo.org>2021-08-09 00:11:09 +0200
committerLouis Sautier <sbraz@gentoo.org>2021-08-09 00:18:19 +0200
commit5ce9f52c05edbe92da383b16883fd2e8e3ac8530 (patch)
tree742fa4f8ff77dd928034b13c4164256b3628f127 /dev-python
parentdev-python/rencode: enable py3.10, fix deps+license, add tests (diff)
downloadgentoo-5ce9f52c05edbe92da383b16883fd2e8e3ac8530.tar.gz
gentoo-5ce9f52c05edbe92da383b16883fd2e8e3ac8530.tar.bz2
gentoo-5ce9f52c05edbe92da383b16883fd2e8e3ac8530.zip
dev-python/python-ldap: enable py3.10, use epytest
Also remove reference to treecleaned pyldap. Signed-off-by: Louis Sautier <sbraz@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/python-ldap/python-ldap-3.3.1.ebuild8
1 files changed, 3 insertions, 5 deletions
diff --git a/dev-python/python-ldap/python-ldap-3.3.1.ebuild b/dev-python/python-ldap/python-ldap-3.3.1.ebuild
index ba9b8d5ece63..bd5fd8bb1e72 100644
--- a/dev-python/python-ldap/python-ldap-3.3.1.ebuild
+++ b/dev-python/python-ldap/python-ldap-3.3.1.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( pypy3 python3_{7..9} )
+PYTHON_COMPAT=( pypy3 python3_{7..10} )
inherit distutils-r1
@@ -25,7 +25,6 @@ IUSE="examples sasl ssl"
# We do not need OpenSSL, it is never directly used:
# https://github.com/python-ldap/python-ldap/issues/224
RDEPEND="
- !dev-python/pyldap
>=dev-python/pyasn1-0.3.7[${PYTHON_USEDEP}]
>=dev-python/pyasn1-modules-0.1.5[${PYTHON_USEDEP}]
>net-nds/openldap-2.4.11:=[sasl?,ssl?]
@@ -71,8 +70,7 @@ python_test() {
t_slapdobject.py
)
pushd Tests >/dev/null || die
- pytest -vv ${ignored_tests[@]/#/--ignore } \
- || die "tests failed with ${EPYTHON}"
+ epytest ${ignored_tests[@]/#/--ignore }
popd > /dev/null || die
}