summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2018-06-19 21:09:55 +0200
committerPatrice Clement <monsieurp@gentoo.org>2018-06-19 21:13:18 +0200
commit6b6b91fb176a6d226d2d276f85f7cd7a834b7bcb (patch)
treedeab07181fa1140fa862e61bbfedcbaacc357322 /dev-python
parentdev-python/xstatic-jquery: new package. (diff)
downloadgentoo-6b6b91fb176a6d226d2d276f85f7cd7a834b7bcb.tar.gz
gentoo-6b6b91fb176a6d226d2d276f85f7cd7a834b7bcb.tar.bz2
gentoo-6b6b91fb176a6d226d2d276f85f7cd7a834b7bcb.zip
dev-python/xstatic-patternfly: new package.
Dependency of ARA. Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/xstatic-patternfly/Manifest1
-rw-r--r--dev-python/xstatic-patternfly/metadata.xml11
-rw-r--r--dev-python/xstatic-patternfly/xstatic-patternfly-3.21.0.1.ebuild33
3 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/xstatic-patternfly/Manifest b/dev-python/xstatic-patternfly/Manifest
new file mode 100644
index 000000000000..7ee574e3ed3e
--- /dev/null
+++ b/dev-python/xstatic-patternfly/Manifest
@@ -0,0 +1 @@
+DIST xstatic-patternfly-3.21.0.1.tar.gz 5674553 BLAKE2B 23d14689bfd43195b26f818a0a766aa7ee3f70145baf776790dc642b09a38285370065538ca38aa85ed13924feadff2c97beb1c88026fb98a5d38b502c86ff76 SHA512 14ffebfefe00107cae16d6f2a6cfa11bc7be5b4cfec54f6fe0c0adb0d22b4730870ddd382b202d3489032680d9d4a43aca8ded4b654c44b083ee36c18ca70168
diff --git a/dev-python/xstatic-patternfly/metadata.xml b/dev-python/xstatic-patternfly/metadata.xml
new file mode 100644
index 000000000000..8768d46bf628
--- /dev/null
+++ b/dev-python/xstatic-patternfly/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">XStatic</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/xstatic-patternfly/xstatic-patternfly-3.21.0.1.ebuild b/dev-python/xstatic-patternfly/xstatic-patternfly-3.21.0.1.ebuild
new file mode 100644
index 000000000000..52f725edf4e2
--- /dev/null
+++ b/dev-python/xstatic-patternfly/xstatic-patternfly-3.21.0.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+MY_PN="XStatic-Patternfly"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="XStatic Patternfly package"
+HOMEPAGE="https://pypi.org/project/XStatic-Patternfly"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="dev-python/xstatic[${PYTHON_USEDEP}]"
+
+DEPEND="
+ ${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+S="${WORKDIR}/${MY_P}"
+
+python_install() {
+ distutils-r1_python_install
+ find "${ED}" -name '*.pth' -delete || die
+}