summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-01-22 15:53:12 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2022-01-23 20:49:01 +0200
commit6bbe375254ab9f2f44303d6525dd32579b0345fc (patch)
tree13f5abb1da4bc4bd7b80d741f503b5b8d03cf2ca /dev-python
parentdev-python/markdown-it-py: new package, add 2.0.0 (diff)
downloadgentoo-6bbe375254ab9f2f44303d6525dd32579b0345fc.tar.gz
gentoo-6bbe375254ab9f2f44303d6525dd32579b0345fc.tar.bz2
gentoo-6bbe375254ab9f2f44303d6525dd32579b0345fc.zip
dev-python/mdit-py-plugins: new package, add 0.3.0
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/mdit-py-plugins/Manifest1
-rw-r--r--dev-python/mdit-py-plugins/mdit-py-plugins-0.3.0.ebuild31
-rw-r--r--dev-python/mdit-py-plugins/metadata.xml13
3 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/mdit-py-plugins/Manifest b/dev-python/mdit-py-plugins/Manifest
new file mode 100644
index 000000000000..c04b4ab0815a
--- /dev/null
+++ b/dev-python/mdit-py-plugins/Manifest
@@ -0,0 +1 @@
+DIST mdit-py-plugins-0.3.0.gh.tar.gz 50654 BLAKE2B e84842e7cada1d9239f1d449c1a21ed654ab13017ea92f82190053b37371bc7e06d7afb65f6f56f7fa935666d24d05dca99628121bd4092a1143c289588ddfa4 SHA512 dd6aa738c6d93e45437326b1be52e0a9fc411aa3beacb61690919c272979c97ac1b38116b1ebb01c7d8fe724d4af9621c81ccd45131a690df8a2c0c325eef0e8
diff --git a/dev-python/mdit-py-plugins/mdit-py-plugins-0.3.0.ebuild b/dev-python/mdit-py-plugins/mdit-py-plugins-0.3.0.ebuild
new file mode 100644
index 000000000000..8cdbd10b5c1c
--- /dev/null
+++ b/dev-python/mdit-py-plugins/mdit-py-plugins-0.3.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1
+
+DESCRIPTION="Collection of plugins for markdown-it-py"
+HOMEPAGE="https://pypi.org/project/mdit-py-plugins/
+ https://github.com/executablebooks/mdit-py-plugins"
+SRC_URI="
+ https://github.com/executablebooks/mdit-py-plugins/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-python/markdown-it-py[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-regressions[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
diff --git a/dev-python/mdit-py-plugins/metadata.xml b/dev-python/mdit-py-plugins/metadata.xml
new file mode 100644
index 000000000000..95553c8241b9
--- /dev/null
+++ b/dev-python/mdit-py-plugins/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="pypi">mdit-py-plugins</remote-id>
+ <remote-id type="github">executablebooks/mdit-py-plugins</remote-id>
+ </upstream>
+</pkgmetadata>