summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOz N Tiram <oz.tiram@gmail.com>2020-12-09 21:59:22 +0100
committerJoonas Niilola <juippis@gentoo.org>2020-12-13 12:44:20 +0200
commit998ea05677d8fcc151cd33fc491e7513e06cd02f (patch)
treec7f23aeb243d12deba70a21fbdccdeff0aa35224 /dev-python
parentdev-python/pipenv: drop old version (diff)
downloadgentoo-998ea05677d8fcc151cd33fc491e7513e06cd02f.tar.gz
gentoo-998ea05677d8fcc151cd33fc491e7513e06cd02f.tar.bz2
gentoo-998ea05677d8fcc151cd33fc491e7513e06cd02f.zip
dev-python/pipenv: bump to version 2020.11.15
Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Oz Tiram <oz.tiram@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/18458 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pipenv/Manifest1
-rw-r--r--dev-python/pipenv/pipenv-2020.11.15.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/dev-python/pipenv/Manifest b/dev-python/pipenv/Manifest
index f8d9b27c9b40..f9c16b0765f3 100644
--- a/dev-python/pipenv/Manifest
+++ b/dev-python/pipenv/Manifest
@@ -1 +1,2 @@
+DIST pipenv-2020.11.15.tar.gz 11603983 BLAKE2B 552c35c942f9ece0f52419b6090b87c7dce0c49dd9dc12f8c5b3eb311058fc770ec9e2b141e960d357064c66c6de7cd0892d2dd19868e5cdaee0f302f98fb0ff SHA512 d312059b3fefc97d4cd79bf2b75d6bde1d117d92c0a299c30181a60ebea662a6c3dff0ca7b92c610dd8eb0c873509dd23c9a891761d0d47d0bba2cab738c830d
DIST pipenv-2020.11.4.tar.gz 11574683 BLAKE2B cb2ac4ba6b07377a3a5540b23756afac38a02691e495ba93031815417d001701b919221fd83d0f9e6b94d4f28c1fa754c2c31e289830305a8c8ac75d847209c4 SHA512 c9015eb9a449fa517f31619d1fec5d99882da915a50e189ba6ab9c7c147862f9734f0df200330d666380afe5d2cf52d18015c539635ca6459042ab50d3ccd059
diff --git a/dev-python/pipenv/pipenv-2020.11.15.ebuild b/dev-python/pipenv/pipenv-2020.11.15.ebuild
new file mode 100644
index 000000000000..eade778d1d8d
--- /dev/null
+++ b/dev-python/pipenv/pipenv-2020.11.15.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_6 python3_7 python3_8 )
+
+inherit distutils-r1
+
+MY_PV=${PV/_beta/b}
+DESCRIPTION="Python Development Workflow for Humans"
+HOMEPAGE="https://github.com/pypa/pipenv https://pypi.org/project/pipenv/"
+SRC_URI="https://github.com/pypa/pipenv/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}"/${PN}-${MY_PV}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ dev-python/certifi[${PYTHON_USEDEP}]
+ dev-python/pip[${PYTHON_USEDEP}]
+ >=dev-python/virtualenv-20.0.35[${PYTHON_USEDEP}]
+ dev-python/virtualenv-clone[${PYTHON_USEDEP}]
+ "
+
+BDEPEND="
+ ${RDEPEND}
+ test? (
+ dev-python/flaky[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ )"
+
+src_prepare() {
+ # remove vendored version of PyYAML that is backported to Python2
+ # this should be removed when upstream removes support for Python2
+ rm -vR "${S}/${PN}/patched/yaml2/" || die
+ # disable running of unittests in parallel with xdist
+ sed -i 's/addopts = -ra -n auto/;&/g' setup.cfg || die
+ sed -i 's/plugins = xdist/;&/g' setup.cfg || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ pytest -vvv -x -m "not cli and not needs_internet" tests/unit/ || die
+}