summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-12-01 09:58:50 +0100
committerMichał Górny <mgorny@gentoo.org>2020-12-01 11:32:00 +0100
commita00908d9d625bfcf32ce9c0872a6b36ade6cfdfb (patch)
treec0f3ac83ac758884a6ea687fc4e389428ff0d01e /dev-python
parentdev-python/stevedore: Bump to 3.3.0 (diff)
downloadgentoo-a00908d9d625bfcf32ce9c0872a6b36ade6cfdfb.tar.gz
gentoo-a00908d9d625bfcf32ce9c0872a6b36ade6cfdfb.tar.bz2
gentoo-a00908d9d625bfcf32ce9c0872a6b36ade6cfdfb.zip
dev-python/llvmlite: Bump to 0.35.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/llvmlite/Manifest1
-rw-r--r--dev-python/llvmlite/llvmlite-0.35.0.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/dev-python/llvmlite/Manifest b/dev-python/llvmlite/Manifest
index 0ab640394b0e..f06c761a5fbd 100644
--- a/dev-python/llvmlite/Manifest
+++ b/dev-python/llvmlite/Manifest
@@ -1 +1,2 @@
DIST llvmlite-0.34.0.gh.tar.gz 210438 BLAKE2B 832ec28047a51b2874a0de5885445b9d77942a70f86620dfb0b25ff0b17395b6009d31d5e9f27ddf02c19ae97bd5b325fc49227fdc0499a9f5fa3bde44e6b564 SHA512 5540df4ebad835e294c00cc09ab1230a530566f563f751f890752f6e22f7b2a04aedcbb53dbbb8e323198d05c80bc9699b593d919eaf1af60fa6f94ff6f50bb1
+DIST llvmlite-0.35.0.gh.tar.gz 228089 BLAKE2B 5cee01244552cfc1c2ba979709170484ed253f52c5c47a4a254bf7d26c935ff0d2a858b7a7f4ec7719644495383128adab11a1287849cd426b7997da4a59efeb SHA512 345b6321277749a169cd87e152261ef499edbf18d18ef7085017c111f2892eac0241529cfae9c6eaaeb68cdb4d726965ed03b4d5a836501dcbdaa73d3c0796fd
diff --git a/dev-python/llvmlite/llvmlite-0.35.0.ebuild b/dev-python/llvmlite/llvmlite-0.35.0.ebuild
new file mode 100644
index 000000000000..3fa3c11d9cb7
--- /dev/null
+++ b/dev-python/llvmlite/llvmlite-0.35.0.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit distutils-r1 llvm
+
+DESCRIPTION="Python wrapper around the llvm C++ library"
+HOMEPAGE="https://llvmlite.pydata.org/"
+SRC_URI="https://github.com/numba/llvmlite/archive/v${PV/_/}.tar.gz -> ${P/_/}.gh.tar.gz"
+S=${WORKDIR}/${P/_/}
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="examples"
+
+LLVM_MAX_SLOT=10
+
+RDEPEND="
+ sys-devel/llvm:${LLVM_MAX_SLOT}
+ sys-libs/zlib:0=
+"
+DEPEND="${RDEPEND}"
+
+python_configure_all() {
+ # upstream's build system is just horrible, and they ignored the PR
+ # fixing it, so let's build the shared lib properly using implicit
+ # make rules
+
+ export LDLIBS=$(llvm-config --libs all)
+ export CXXFLAGS="$(llvm-config --cxxflags) -fPIC ${CXXFLAGS}"
+ export LDFLAGS="$(llvm-config --ldflags) ${LDFLAGS}"
+
+ local files=( ffi/*.cpp )
+ emake -f - <<EOF
+ffi/libllvmlite.so: ${files[*]/.cpp/.o}
+ \$(CXX) -shared \$(CXXFLAGS) \$(LDFLAGS) -o \$@ \$^ \$(LDLIBS)
+EOF
+
+ export LLVMLITE_SKIP_LLVM_VERSION_CHECK=1
+}
+
+python_test() {
+ "${EPYTHON}" runtests.py -v || die "Tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}