summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sbraz@gentoo.org>2021-08-09 00:12:01 +0200
committerLouis Sautier <sbraz@gentoo.org>2021-08-09 00:18:56 +0200
commita50a60262ed09ec607568bb631e6e418c59f3809 (patch)
treeaeb9b6dfe20ca928b111b76bd1d7bb5ff12bb07b /dev-python
parentdev-python/python-ldap: enable py3.10, use epytest (diff)
downloadgentoo-a50a60262ed09ec607568bb631e6e418c59f3809.tar.gz
gentoo-a50a60262ed09ec607568bb631e6e418c59f3809.tar.bz2
gentoo-a50a60262ed09ec607568bb631e6e418c59f3809.zip
dev-python/python-ldap: sync live ebuild with 3.3.1
Signed-off-by: Louis Sautier <sbraz@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/python-ldap/python-ldap-9999.ebuild8
1 files changed, 3 insertions, 5 deletions
diff --git a/dev-python/python-ldap/python-ldap-9999.ebuild b/dev-python/python-ldap/python-ldap-9999.ebuild
index 1231c05f5b4d..2abb6ecf585b 100644
--- a/dev-python/python-ldap/python-ldap-9999.ebuild
+++ b/dev-python/python-ldap/python-ldap-9999.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( pypy3 python3_{7..9} )
+PYTHON_COMPAT=( pypy3 python3_{7..10} )
inherit distutils-r1
@@ -25,7 +25,6 @@ IUSE="examples sasl ssl"
# We do not need OpenSSL, it is never directly used:
# https://github.com/python-ldap/python-ldap/issues/224
RDEPEND="
- !dev-python/pyldap
>=dev-python/pyasn1-0.3.7[${PYTHON_USEDEP}]
>=dev-python/pyasn1-modules-0.1.5[${PYTHON_USEDEP}]
>net-nds/openldap-2.4.11:=[sasl?,ssl?]
@@ -71,8 +70,7 @@ python_test() {
t_slapdobject.py
)
pushd Tests >/dev/null || die
- pytest -vv ${ignored_tests[@]/#/--ignore } \
- || die "tests failed with ${EPYTHON}"
+ epytest ${ignored_tests[@]/#/--ignore }
popd > /dev/null || die
}