summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2021-05-20 16:51:33 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2021-05-20 17:02:31 +0200
commita5ccd8b420cb9f7ed7b30eac6b7eec10760072b9 (patch)
tree422182845c62579d269cfa540c7ab2405e1e4bd8 /dev-python
parentdev-python/sphobjinv: import from ::guru (diff)
downloadgentoo-a5ccd8b420cb9f7ed7b30eac6b7eec10760072b9.tar.gz
gentoo-a5ccd8b420cb9f7ed7b30eac6b7eec10760072b9.tar.bz2
gentoo-a5ccd8b420cb9f7ed7b30eac6b7eec10760072b9.zip
dev-python/sphinx-autodoc-typehints: import from ::guru
Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/sphinx-autodoc-typehints/Manifest1
-rw-r--r--dev-python/sphinx-autodoc-typehints/metadata.xml17
-rw-r--r--dev-python/sphinx-autodoc-typehints/sphinx-autodoc-typehints-1.12.0.ebuild43
3 files changed, 61 insertions, 0 deletions
diff --git a/dev-python/sphinx-autodoc-typehints/Manifest b/dev-python/sphinx-autodoc-typehints/Manifest
new file mode 100644
index 000000000000..c3b115698f0f
--- /dev/null
+++ b/dev-python/sphinx-autodoc-typehints/Manifest
@@ -0,0 +1 @@
+DIST sphinx-autodoc-typehints-1.12.0.tar.gz 19494 BLAKE2B beacc4f8ab453612dfd5264f1c65fd6bdd957269a28ee5b71b762d0baf5a3d4be58398b32d4263f996648281c1139f47a7564e8fc6444a94095f6a970b4cc27a SHA512 92fa340495a48111fa3d600d8c46d83214505ac2a5c71cb1303e846ac439f1e0ff14f8ce8dfd5ffdb6a62a9fa15dde8a5227f946840d9377ad5f7fde25894b75
diff --git a/dev-python/sphinx-autodoc-typehints/metadata.xml b/dev-python/sphinx-autodoc-typehints/metadata.xml
new file mode 100644
index 000000000000..a8e231b705d7
--- /dev/null
+++ b/dev-python/sphinx-autodoc-typehints/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="person">
+ <email>andrewammerlaan@gentoo.org</email>
+ <name>Andrew Ammerlaan</name>
+ </maintainer>
+ <longdescription lang="en">
+This extension allows you to use Python 3 annotations for documenting acceptable argument types and return value types of functions. This allows you to use type hints in a very natural fashion
+ </longdescription>
+ <upstream>
+ <remote-id type="github">agronholm/sphinx-autodoc-typehints</remote-id>
+ <remote-id type="pypi">sphinx-autodoc-typehints</remote-id>
+ </upstream>
+ <stabilize-allarches/>
+</pkgmetadata>
diff --git a/dev-python/sphinx-autodoc-typehints/sphinx-autodoc-typehints-1.12.0.ebuild b/dev-python/sphinx-autodoc-typehints/sphinx-autodoc-typehints-1.12.0.ebuild
new file mode 100644
index 000000000000..1999e89a2278
--- /dev/null
+++ b/dev-python/sphinx-autodoc-typehints/sphinx-autodoc-typehints-1.12.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Type hints support for the Sphinx autodoc extension "
+HOMEPAGE="
+ https://github.com/agronholm/sphinx-autodoc-typehints/
+ https://pypi.org/project/sphinx-autodoc-typehints/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+KEYWORDS="~amd64"
+SLOT="0"
+
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/sphobjinv[${PYTHON_USEDEP}]
+ dev-python/typing-extensions[${PYTHON_USEDEP}]
+ )
+"
+
+# https://github.com/agronholm/sphinx-autodoc-typehints/issues/176
+RDEPEND="<dev-python/sphinx-4[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # why on earth would this have to connect to the internet
+ sed -i \
+ -e 's:test_parse_annotation:_&:' \
+ -e 's:test_format_annotation:_&:' \
+ -e 's:test_format_annotation_both_libs:_&:' \
+ tests/test_sphinx_autodoc_typehints.py || die
+
+ distutils-r1_python_prepare_all
+}