summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2019-08-23 18:54:29 +0200
committerBernard Cafarelli <voyageur@gentoo.org>2019-08-23 18:54:46 +0200
commita9c49ffd2b27ce44340091c71ab4f8e99bc4d7f2 (patch)
tree8f3c0230ff3bc0ff6f72ae8335d2ab0118f12778 /dev-python
parentapp-text/paperwork: 1.3.0 bump (diff)
downloadgentoo-a9c49ffd2b27ce44340091c71ab4f8e99bc4d7f2.tar.gz
gentoo-a9c49ffd2b27ce44340091c71ab4f8e99bc4d7f2.tar.bz2
gentoo-a9c49ffd2b27ce44340091c71ab4f8e99bc4d7f2.zip
dev-python/ntlm-auth: 1.4.0 bump
Package-Manager: Portage-2.3.72, Repoman-2.3.17 Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/ntlm-auth/Manifest1
-rw-r--r--dev-python/ntlm-auth/ntlm-auth-1.4.0.ebuild22
2 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/ntlm-auth/Manifest b/dev-python/ntlm-auth/Manifest
index 5951e3109cf1..16db345442de 100644
--- a/dev-python/ntlm-auth/Manifest
+++ b/dev-python/ntlm-auth/Manifest
@@ -1,3 +1,4 @@
DIST ntlm-auth-1.1.0.tar.gz 38624 BLAKE2B 22c6fbe7ef95b7ee88b803b7ccc5f63f1a27ec9285a4527dac20c3d774abef9765f8a7aa7265effd70869f02e09e6d3b8012c50b703c3b0979e41c0134843be2 SHA512 0c41cfab957c48d5fabf391422323556289cc6d8ba5a50c82bb179f6cdbf68528f005c3987e0b47fb47aff2fbcf00deebb0ac4220df6bd08d335879344f8470a
DIST ntlm-auth-1.2.0.tar.gz 40006 BLAKE2B 2fbe7533411dde27938412b3e5e1292ce0fa197abb048c0e52f521ff351bd7e51bdb83b5fd8c1f05e0bb3ce206a4442b8b7059c859eea7333ee2d20ed2e7f7dd SHA512 4fa537c5a6a7f3493df2fdf49261f9588b7aac876f72b7a7ef5b8a7a1dd971d9426dacdc8bbf520cecdbe5b7adb916ddcad9e9cf4df725b69793299304601912
DIST ntlm-auth-1.3.0.tar.gz 40684 BLAKE2B 74c2b914f508b5291cc2a23ae99417db5e5ad9fe107c03f63c795bd4da202db2f1a4f6f289645d2164e708a5a5a2e3bf626aa749dff3367420d669965c462b71 SHA512 e2d5401161ba6f9fed377a7bfed501d49ad64d5104accd7df298747abade34a3ddac9e68332416a3ab68156e9bbf7a8de6a8a271542d080cafaa84ee19f01986
+DIST ntlm-auth-1.4.0.tar.gz 40745 BLAKE2B bf2c0dab7303cb0f87d83ed11d79bc12b8f74095f2f251c190eb43879bc0e9419dedf706fcb4929c51138658910bdfa836778084b34c974ca120aeb848e2da0e SHA512 abe0260c66e2b5f57c1fd672ea121129926f1c32020166dd61973cf51f6bd320f6057f3a148d602b96d8417c2ad57c335048da185100417401e049ff14b46004
diff --git a/dev-python/ntlm-auth/ntlm-auth-1.4.0.ebuild b/dev-python/ntlm-auth/ntlm-auth-1.4.0.ebuild
new file mode 100644
index 000000000000..2f680d17f344
--- /dev/null
+++ b/dev-python/ntlm-auth/ntlm-auth-1.4.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Calculates NTLM Authentication codes"
+HOMEPAGE="https://github.com/jborean93/ntlm-auth"
+SRC_URI="https://github.com/jborean93/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/ordereddict[${PYTHON_USEDEP}]' python2_7)"
+DEPEND="${RDEPEND}"