summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2018-07-12 20:36:45 +0200
committerMichał Górny <mgorny@gentoo.org>2018-07-12 20:49:35 +0200
commitaa6fd714174d4291c3704bcf0e1f944560176348 (patch)
tree14802ec423f8ceba0769431f5aa8c1ee15c548cf /dev-python
parentdev-python/sphinx: Disable test_latex_remote_images due to network (diff)
downloadgentoo-aa6fd714174d4291c3704bcf0e1f944560176348.tar.gz
gentoo-aa6fd714174d4291c3704bcf0e1f944560176348.tar.bz2
gentoo-aa6fd714174d4291c3704bcf0e1f944560176348.zip
dev-python/sphinx: Make python_test() simpler
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/sphinx/sphinx-1.7.5-r1.ebuild4
1 files changed, 1 insertions, 3 deletions
diff --git a/dev-python/sphinx/sphinx-1.7.5-r1.ebuild b/dev-python/sphinx/sphinx-1.7.5-r1.ebuild
index b39431a75c07..86a61f664a74 100644
--- a/dev-python/sphinx/sphinx-1.7.5-r1.ebuild
+++ b/dev-python/sphinx/sphinx-1.7.5-r1.ebuild
@@ -93,7 +93,5 @@ python_compile_all() {
python_test() {
mkdir -p "${BUILD_DIR}/sphinx_tempdir" || die
local -x SPHINX_TEST_TEMPDIR="${BUILD_DIR}/sphinx_tempdir"
- cp -r -l tests "${BUILD_DIR}"/ || die "Failed to copy tests"
- cp Makefile "${BUILD_DIR}"/ || die "Failed to copy Makefile"
- emake test
+ py.test -vv || die "Tests fail with ${EPYTHON}"
}