summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2022-04-03 22:39:45 +0200
committerMaciej Barć <xgqt@gentoo.org>2022-04-05 14:31:30 +0200
commitacf0097a0a026d935f073f9dfe82f1a43a3dac3e (patch)
tree68f533ab7f19679635d048a40421285c37466d4a /dev-python
parentdev-python/spotipy: new package; add version 2.19.0 (diff)
downloadgentoo-acf0097a0a026d935f073f9dfe82f1a43a3dac3e.tar.gz
gentoo-acf0097a0a026d935f073f9dfe82f1a43a3dac3e.tar.bz2
gentoo-acf0097a0a026d935f073f9dfe82f1a43a3dac3e.zip
dev-python/ffmpeg-python: new package; add version 0.2.0
Bug: https://github.com/deepjyoti30/ytmdl/issues/222 Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/ffmpeg-python/Manifest1
-rw-r--r--dev-python/ffmpeg-python/ffmpeg-python-0.2.0.ebuild38
-rw-r--r--dev-python/ffmpeg-python/files/ffmpeg-python-0.2.0-_run.py-collections.patch12
-rw-r--r--dev-python/ffmpeg-python/files/ffmpeg-python-0.2.0-setup.py-pytest-runner.patch11
-rw-r--r--dev-python/ffmpeg-python/metadata.xml13
5 files changed, 75 insertions, 0 deletions
diff --git a/dev-python/ffmpeg-python/Manifest b/dev-python/ffmpeg-python/Manifest
new file mode 100644
index 000000000000..c1f30ed46ffd
--- /dev/null
+++ b/dev-python/ffmpeg-python/Manifest
@@ -0,0 +1 @@
+DIST ffmpeg-python-0.2.0.tar.gz 3267771 BLAKE2B 8bca4a24434b6c7a542e3c178cb7bf1e5650f9763636d5378f9652cdd07ef19b0e96007d6bb71fdf1664efb6e33d597844c7d6a44dc8dcb1c083e21f53649469 SHA512 933ed958d61536bbbc0e0b08e19521c4b1f7df1cfe97de0b3d149a2748c5bd74915a3134861e8ecb1f92d5860315228b76aefcd087fcf07e188a56c651f5e301
diff --git a/dev-python/ffmpeg-python/ffmpeg-python-0.2.0.ebuild b/dev-python/ffmpeg-python/ffmpeg-python-0.2.0.ebuild
new file mode 100644
index 000000000000..4ee086b79602
--- /dev/null
+++ b/dev-python/ffmpeg-python/ffmpeg-python-0.2.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python bindings for FFmpeg with complex filtering support"
+HOMEPAGE="https://github.com/kkroening/ffmpeg-python"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/kkroening/${PN}.git"
+else
+ SRC_URI="https://github.com/kkroening/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="Apache-2.0"
+SLOT="0"
+
+RDEPEND="
+ dev-python/future[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ media-video/ffmpeg
+"
+BDEPEND="test? ( dev-python/pytest-mock[${PYTHON_USEDEP}] )"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-_run.py-collections.patch
+ "${FILESDIR}"/${P}-setup.py-pytest-runner.patch
+)
+
+distutils_enable_tests pytest
+distutils_enable_sphinx doc/src
diff --git a/dev-python/ffmpeg-python/files/ffmpeg-python-0.2.0-_run.py-collections.patch b/dev-python/ffmpeg-python/files/ffmpeg-python-0.2.0-_run.py-collections.patch
new file mode 100644
index 000000000000..6231ba17b86e
--- /dev/null
+++ b/dev-python/ffmpeg-python/files/ffmpeg-python-0.2.0-_run.py-collections.patch
@@ -0,0 +1,12 @@
+index afc504d..bf43c06 100644
+--- a/ffmpeg/_run.py
++++ b/ffmpeg/_run.py
+@@ -137,7 +137,7 @@ def _get_output_args(node, stream_name_map):
+ if 'video_size' in kwargs:
+ video_size = kwargs.pop('video_size')
+ if not isinstance(video_size, basestring) and isinstance(
+- video_size, collections.Iterable
++ video_size, collections.abc.Iterable
+ ):
+ video_size = '{}x{}'.format(video_size[0], video_size[1])
+ args += ['-video_size', video_size]
diff --git a/dev-python/ffmpeg-python/files/ffmpeg-python-0.2.0-setup.py-pytest-runner.patch b/dev-python/ffmpeg-python/files/ffmpeg-python-0.2.0-setup.py-pytest-runner.patch
new file mode 100644
index 000000000000..67fbb2308a37
--- /dev/null
+++ b/dev-python/ffmpeg-python/files/ffmpeg-python-0.2.0-setup.py-pytest-runner.patch
@@ -0,0 +1,11 @@
+index 0282c67..2011d2c 100644
+--- a/setup.py
++++ b/setup.py
+@@ -60,7 +60,6 @@ keywords = misc_keywords + file_formats
+ setup(
+ name='ffmpeg-python',
+ packages=['ffmpeg'],
+- setup_requires=['pytest-runner'],
+ tests_require=['pytest', 'pytest-mock'],
+ version=version,
+ description='Python bindings for FFmpeg - with complex filtering support',
diff --git a/dev-python/ffmpeg-python/metadata.xml b/dev-python/ffmpeg-python/metadata.xml
new file mode 100644
index 000000000000..b908e7d7cbe1
--- /dev/null
+++ b/dev-python/ffmpeg-python/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="person">
+ <email>xgqt@gentoo.org</email>
+ <name>Maciej Barć</name>
+ </maintainer>
+ <upstream>
+ <bugs-to>https://github.com/kkroening/ffmpeg-python/issues/</bugs-to>
+ <remote-id type="github">kkroening/ffmpeg-python</remote-id>
+ </upstream>
+</pkgmetadata>