summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-01-22 16:02:01 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2022-01-23 20:49:01 +0200
commitb1be4b9ad336df528593ccd4d438a025816a1462 (patch)
treec9a4d67265ef2fcb8884d14126924d8c6ed87018 /dev-python
parentdev-python/mdit-py-plugins: new package, add 0.3.0 (diff)
downloadgentoo-b1be4b9ad336df528593ccd4d438a025816a1462.tar.gz
gentoo-b1be4b9ad336df528593ccd4d438a025816a1462.tar.bz2
gentoo-b1be4b9ad336df528593ccd4d438a025816a1462.zip
dev-python/pytest-param-files: new package, 0.3.3
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pytest-param-files/Manifest1
-rw-r--r--dev-python/pytest-param-files/metadata.xml13
-rw-r--r--dev-python/pytest-param-files/pytest-param-files-0.3.3.ebuild25
3 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/pytest-param-files/Manifest b/dev-python/pytest-param-files/Manifest
new file mode 100644
index 000000000000..1654e8c02308
--- /dev/null
+++ b/dev-python/pytest-param-files/Manifest
@@ -0,0 +1 @@
+DIST pytest-param-files-0.3.3.gh.tar.gz 6858 BLAKE2B 6614b00dcfab63241daee0951bea442afb885942c4ab1ce0b2f6b4c3fe1e0a6048955d79cb1bd703f31ffedaede19b36f40caded98e0c8dc014b64e847110a00 SHA512 d52d0aa44088879ee5cd55f8af56ed649a1a82420bed357be043fdcc0df4899002cae36d95c6864126eaaa97877a21aedabb00dd12a8730d6aee3bcaecdcee62
diff --git a/dev-python/pytest-param-files/metadata.xml b/dev-python/pytest-param-files/metadata.xml
new file mode 100644
index 000000000000..a59f07232de3
--- /dev/null
+++ b/dev-python/pytest-param-files/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="pypi">pytest_param_files</remote-id>
+ <remote-id type="github">chrisjsewell/pytest-param-files</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pytest-param-files/pytest-param-files-0.3.3.ebuild b/dev-python/pytest-param-files/pytest-param-files-0.3.3.ebuild
new file mode 100644
index 000000000000..1a00f6b23a3a
--- /dev/null
+++ b/dev-python/pytest-param-files/pytest-param-files-0.3.3.ebuild
@@ -0,0 +1,25 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+DISTUTILS_USE_PEP517=flit
+inherit distutils-r1
+
+DESCRIPTION="Pytest parametrize decorators from external files."
+HOMEPAGE="https://pypi.org/project/pytest_param_files/
+ https://github.com/chrisjsewell/pytest-param-files"
+SRC_URI="
+ https://github.com/chrisjsewell/pytest-param-files/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND=""
+RDEPEND="dev-python/pytest[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest