summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-10-22 07:38:36 +0200
committerMichał Górny <mgorny@gentoo.org>2020-10-22 07:38:36 +0200
commitc3c8c839bb085e87e324cab30b51ff0b2f710017 (patch)
tree5b65646d2eb8d8fbffb4c524accae3007e918fe8 /dev-python
parentdev-python/pytrie: Bump to 0.4.0 (diff)
downloadgentoo-c3c8c839bb085e87e324cab30b51ff0b2f710017.tar.gz
gentoo-c3c8c839bb085e87e324cab30b51ff0b2f710017.tar.bz2
gentoo-c3c8c839bb085e87e324cab30b51ff0b2f710017.zip
dev-python/kiwisolver: Bump to 1.3.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/kiwisolver/Manifest1
-rw-r--r--dev-python/kiwisolver/kiwisolver-1.3.0.ebuild22
2 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/kiwisolver/Manifest b/dev-python/kiwisolver/Manifest
index 57b68f1925c4..d7004669eba5 100644
--- a/dev-python/kiwisolver/Manifest
+++ b/dev-python/kiwisolver/Manifest
@@ -1 +1,2 @@
DIST kiwisolver-1.2.0.tar.gz 54244 BLAKE2B 42590c2cbb78b3c2ed568373616e772326bf5a0e133396d9e9cf6468132ec88b45d40f68f51baff7bc22ca261567ebab81cf2585009657bd2a59df4e97c33f1f SHA512 05541ff46cc64b9958d714452138dc7bb343e6cc9308408a3f8cf25242e9640af37f8bfd22a7038e8ca70a895f57bdb983346259bce22b1630ac10b974d00a0e
+DIST kiwisolver-1.3.0.tar.gz 86440 BLAKE2B 931a230909a7778aac3bc93fb24538c7b9e0a3cf1dea33fcf374fd6576d56b80a50597d14c6431f659326222c8810416897fcc9ce2725ca5341891f65aedc5b2 SHA512 64bb475f86e6f409318c5030cd2874bf060c26bf6c1ea62bfb96c1ae27f7326fcd6fc575cbdad7351808d18ae9b9f6664eb312019d432cd6a4c0b8af4fa317b6
diff --git a/dev-python/kiwisolver/kiwisolver-1.3.0.ebuild b/dev-python/kiwisolver/kiwisolver-1.3.0.ebuild
new file mode 100644
index 000000000000..2d2ec37813ab
--- /dev/null
+++ b/dev-python/kiwisolver/kiwisolver-1.3.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="An efficient C++ implementation of the Cassowary constraint solving algorithm"
+HOMEPAGE="https://github.com/nucleic/kiwi"
+SRC_URI="https://github.com/nucleic/kiwi/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}"/kiwi-${PV}
+
+LICENSE="Clear-BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+
+RDEPEND="
+ >=dev-python/cppy-1.1.0[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest