summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2021-12-03 22:46:32 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2021-12-03 22:47:33 +0200
commitcf837bbd487521ce80220ecba5e4238215bbe77a (patch)
tree07084cd7fa32f42c7bd4e7fddae5c85d08abcf33 /dev-python
parentdev-python/asgiref: Stabilize 3.4.1-r1 hppa, #803806 (diff)
downloadgentoo-cf837bbd487521ce80220ecba5e4238215bbe77a.tar.gz
gentoo-cf837bbd487521ce80220ecba5e4238215bbe77a.tar.bz2
gentoo-cf837bbd487521ce80220ecba5e4238215bbe77a.zip
dev-python/watchgod: increase timeout for slow systems
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/watchgod/watchgod-0.7.ebuild12
1 files changed, 12 insertions, 0 deletions
diff --git a/dev-python/watchgod/watchgod-0.7.ebuild b/dev-python/watchgod/watchgod-0.7.ebuild
index 92e36bbd9492..7efbc07f534f 100644
--- a/dev-python/watchgod/watchgod-0.7.ebuild
+++ b/dev-python/watchgod/watchgod-0.7.ebuild
@@ -27,3 +27,15 @@ BDEPEND="
"
distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # flaky test on slow systems, https://github.com/samuelcolvin/watchgod/issues/84
+ tests/test_watch.py::test_awatch_log
+)
+
+src_prepare() {
+ # increase timeout
+ sed -e '/sleep/s/0.01/1.0/' -i tests/test_watch.py || die
+
+ distutils-r1_src_prepare
+}