summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/watchgod/watchgod-0.7.ebuild12
1 files changed, 12 insertions, 0 deletions
diff --git a/dev-python/watchgod/watchgod-0.7.ebuild b/dev-python/watchgod/watchgod-0.7.ebuild
index 92e36bbd9492..7efbc07f534f 100644
--- a/dev-python/watchgod/watchgod-0.7.ebuild
+++ b/dev-python/watchgod/watchgod-0.7.ebuild
@@ -27,3 +27,15 @@ BDEPEND="
"
distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # flaky test on slow systems, https://github.com/samuelcolvin/watchgod/issues/84
+ tests/test_watch.py::test_awatch_log
+)
+
+src_prepare() {
+ # increase timeout
+ sed -e '/sleep/s/0.01/1.0/' -i tests/test_watch.py || die
+
+ distutils-r1_src_prepare
+}