summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-01-24 22:49:20 +0100
committerMichał Górny <mgorny@gentoo.org>2022-01-24 23:09:50 +0100
commite9515534451ae6dd96108152e84af9e74b59ce2b (patch)
tree509de92b54eef2424b85749c042880a0acddf7b8 /dev-python
parentdev-python/fonttools: Bump to 4.29.0 (diff)
downloadgentoo-e9515534451ae6dd96108152e84af9e74b59ce2b.tar.gz
gentoo-e9515534451ae6dd96108152e84af9e74b59ce2b.tar.bz2
gentoo-e9515534451ae6dd96108152e84af9e74b59ce2b.zip
dev-python/dulwich: Bump to 0.20.32
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/dulwich/Manifest1
-rw-r--r--dev-python/dulwich/dulwich-0.20.32.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/dev-python/dulwich/Manifest b/dev-python/dulwich/Manifest
index 90d6d04db8a8..2f66260ae117 100644
--- a/dev-python/dulwich/Manifest
+++ b/dev-python/dulwich/Manifest
@@ -3,3 +3,4 @@ DIST dulwich-0.20.27.tar.gz 416618 BLAKE2B 73ed04d9fc871a82126e212bdac0eaf235e44
DIST dulwich-0.20.28.tar.gz 416723 BLAKE2B ddbb36c65e1372e1c2fbab5d85ef26a77f40e4763eee8dc5d2ba249a6b4e37bd6e38197eaebbcb46f16df577c0ff4730ec69fff39a549adf2e5d147e7a3eabfc SHA512 5eb90dd888909f787ef5e9f0a79d7db9a31c5897e334a862c1d0593c4f115ff30047f108c7b315e0145e267f581ba0f4fd0fafb7b1b2316d3def4f70697f2e20
DIST dulwich-0.20.30.tar.gz 417219 BLAKE2B 6b5b10a37f2901424b632dad081b9972da5af7475e11389c73f8a64a57ebf421700c6591bfddc5418b9c02d61916894aeeb2371a3ceb514532fd1b9e63dffb2c SHA512 1dd18c047e8bfe9f23a10c0c55b57be7b4d89d93af4a682265dac3bf495d1594057ed755e7caad926100d35e3603006377163dc6ae71bc51a500c744064f8bbc
DIST dulwich-0.20.31.tar.gz 418063 BLAKE2B 7b914ce6509227b48fc716ed4ecabfead8b95fa17661564b3dc6b9abedb2c444d026d1261de9bb7195a14f5ffea9dfcb3103f32784f07731d2101a7c60f1abda SHA512 1f181aa62493fc8cdb2a18183f0aa2f5bb0963c1739423fc6790080bcec9d10368689934bfe8828b502bbe319ade4846428f3c4262666be01ccbce55a8803efa
+DIST dulwich-0.20.32.tar.gz 418100 BLAKE2B 21d41a7b1e491848a11ab3e3b1b63bfbe1798b38ef331136b07609f004e780672477e91a637dd3b1ccd3b26e359461e1a16d759ac2cb98d1091fbdb1968c00a9 SHA512 9af4cb4462ab9a69bea9074aace81eeb8d33087f2c53e64145991913ad132e076b62f7958551729c758cd6eeae029a278723872771ef36b046331c85ebf2fcf4
diff --git a/dev-python/dulwich/dulwich-0.20.32.ebuild b/dev-python/dulwich/dulwich-0.20.32.ebuild
new file mode 100644
index 000000000000..db9d32133a7a
--- /dev/null
+++ b/dev-python/dulwich/dulwich-0.20.32.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Pure-Python implementation of the Git file formats and protocols"
+HOMEPAGE="
+ https://github.com/dulwich/dulwich/
+ https://pypi.org/project/dulwich/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2+ Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="doc examples test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-python/certifi[${PYTHON_USEDEP}]
+ dev-python/urllib3[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ ${RDEPEND}
+ !hppa? ( !ia64? (
+ dev-python/gevent[${PYTHON_USEDEP}]
+ dev-python/geventhttpclient[${PYTHON_USEDEP}]
+ ) )
+ app-crypt/gpgme[python,${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/fastimport[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_sphinx docs
+
+python_test() {
+ # remove interference from the tests that do stuff like user.name
+ unset GIT_AUTHOR_NAME GIT_AUTHOR_EMAIL GIT_AUTHOR_DATE \
+ GIT_COMMITTER_NAME GIT_COMMITTER_EMAIL GIT_COMMITTER_DATE EMAIL
+ # Do not use make check which rebuilds the extension and uses -Werror,
+ # causing unexpected failures.
+ "${EPYTHON}" -m unittest -v dulwich.tests.test_suite ||
+ die "tests failed with ${EPYTHON}"
+}
+
+python_install_all() {
+ if use examples; then
+ docompress -x "/usr/share/doc/${PF}/examples"
+ dodoc -r examples
+ fi
+ distutils-r1_python_install_all
+}