summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNils Freydank <holgersson@posteo.de>2018-10-27 19:54:05 +0200
committerMichał Górny <mgorny@gentoo.org>2018-10-30 10:07:33 +0100
commitf0ffb5105bdb78c21992efc167486e0491c2a424 (patch)
tree7b0ff1696ff11e2f08f01849fc426e003f0686e0 /dev-python
parentdev-python/pytidylib: Bump to 0.3.2 and add python3_7 support (diff)
downloadgentoo-f0ffb5105bdb78c21992efc167486e0491c2a424.tar.gz
gentoo-f0ffb5105bdb78c21992efc167486e0491c2a424.tar.bz2
gentoo-f0ffb5105bdb78c21992efc167486e0491c2a424.zip
dev-python/markdown: Bump to 3.0.1 and add python3_7 support
Signed-off-by: Nils Freydank <holgersson@posteo.de> Package-Manager: Portage-2.3.51, Repoman-2.3.11 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/markdown/Manifest1
-rw-r--r--dev-python/markdown/markdown-3.0.1.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/markdown/Manifest b/dev-python/markdown/Manifest
index a2e10943bf93..b9286f02e6b8 100644
--- a/dev-python/markdown/Manifest
+++ b/dev-python/markdown/Manifest
@@ -1,3 +1,4 @@
DIST Markdown-2.6.5.tar.gz 301781 BLAKE2B 527a84bc8c4a891e64749bce273bf10c439376386c27355f386de8a0dd89e2bf0c1d6cadb0ff937fa3825655ab6220901f7b17ea2d184f3b3d178cbb54af58b8 SHA512 d966136a7184ada4eec70af661aba441694a8c4f59e57d59a28dfbc1649ca1e90cc1e4a29b354b3caf35362e1e0c96eeb3f46c68f82d7a898b76c08866d459d3
DIST Markdown-2.6.8.tar.gz 307330 BLAKE2B 6867f15425bd84bc030ab52000dc2f83bff0c9885854cec4a2a785f80b18129160bc57da30226fe17f42043b4938482e2e4eff9cdb3d4370b0146cc09f1ff576 SHA512 85c1a16ebb50af79f378eb2fa936342df6174a4f597a74fee6d0495ef2bc4c7c8337463799e427cb6788b3429e400309958b5c4784f536593047ab2e47ac7c23
DIST Markdown-2.6.9.tar.gz 271564 BLAKE2B 792e438955a55de9f473107618516d17129caa4d02097d510992d25715a4f28aae005781b3a2e4fe53692bc12e96ab49008b66ff49247bf1685bac4c7607e0b6 SHA512 d00c800dc7c1ae0753cbcddd755ade7d593a8d9c9d4ffc6eb8765233a44027a75b68948c14b4469d7aa0e7f74029e9f60159d81ed40b3d2e770c68a81533ccfa
+DIST Markdown-3.0.1.tar.gz 284084 BLAKE2B 6a9250295057ed32b389e1aeecf9aa3acac37ef48e6ca93a4821eb56a2323d65c1aed99799bf05811f27f45ba61f7bb704f69c6d2be706d8d2764c026e937905 SHA512 c648c1b8ecb3c907ff2bd636ec6c08b4b629967fb916913f77db641f6d61b83d16929af2f15f5695c8cdb9614031606110e02a7e0bbb3aab0be38a8e285f12f1
diff --git a/dev-python/markdown/markdown-3.0.1.ebuild b/dev-python/markdown/markdown-3.0.1.ebuild
new file mode 100644
index 000000000000..3efa195b8f52
--- /dev/null
+++ b/dev-python/markdown/markdown-3.0.1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6,7} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Python implementation of the markdown markup language"
+HOMEPAGE="
+ https://python-markdown.github.io/
+ https://pypi.org/project/Markdown/
+ https://github.com/Python-Markdown/markdown"
+SRC_URI="mirror://pypi/M/${PN^}/${P^}.tar.gz"
+
+LICENSE="|| ( BSD GPL-2 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="doc test pygments"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ dev-python/pytidylib[${PYTHON_USEDEP}]
+ )"
+# source cites pytidylib however from testruns it appears optional
+RDEPEND="pygments? ( dev-python/pygments[${PYTHON_USEDEP}] )"
+
+S="${WORKDIR}/${P^}"
+
+PATCHES=()
+
+python_compile_all() {
+ if use doc; then
+ esetup.py build_docs
+ HTML_DOCS=( "${BUILD_DIR}"/docs/. )
+
+ # remove .txt files
+ find "${BUILD_DIR}"/docs -name '*.txt' -delete || die
+ fi
+}
+
+python_test() {
+ esetup.py test
+}