summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-05-25 20:43:50 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-05-25 21:01:46 +0300
commitfd6cd62864747f88f8e5e7ed5e6aff8e6c4f483e (patch)
treeaeba97e03b4c0641e9a8bc3eb9611d5de6a2cee1 /dev-python
parentx11-wm/twm: Stabilize 1.0.12 sparc, #843167 (diff)
downloadgentoo-fd6cd62864747f88f8e5e7ed5e6aff8e6c4f483e.tar.gz
gentoo-fd6cd62864747f88f8e5e7ed5e6aff8e6c4f483e.tar.bz2
gentoo-fd6cd62864747f88f8e5e7ed5e6aff8e6c4f483e.zip
dev-python/crashtest: EAPI=8, Use PEP517 build
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/crashtest/crashtest-0.3.1-r1.ebuild18
1 files changed, 18 insertions, 0 deletions
diff --git a/dev-python/crashtest/crashtest-0.3.1-r1.ebuild b/dev-python/crashtest/crashtest-0.3.1-r1.ebuild
new file mode 100644
index 000000000000..4ad830f6d949
--- /dev/null
+++ b/dev-python/crashtest/crashtest-0.3.1-r1.ebuild
@@ -0,0 +1,18 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Python library that makes exceptions handling and inspection easier"
+HOMEPAGE="https://github.com/sdispater/crashtest"
+SRC_URI="https://github.com/sdispater/crashtest/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+
+distutils_enable_tests pytest