summaryrefslogtreecommitdiff
path: root/dev-qt
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-10-16 18:22:08 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2021-11-08 00:40:26 +0100
commit9500b55096c81145c77272430f879112fe066a3b (patch)
tree6d1926a78c042a92c01031b4bf568e28b9e03bff /dev-qt
parentdev-qt/qtwayland: 5.15.2-r15 version bump at KDE 992833ca (diff)
downloadgentoo-9500b55096c81145c77272430f879112fe066a3b.tar.gz
gentoo-9500b55096c81145c77272430f879112fe066a3b.tar.bz2
gentoo-9500b55096c81145c77272430f879112fe066a3b.zip
dev-qt/qtwidgets: 5.15.2-r12 version bump at KDE c9fde86b
"Fix memory leak" (in xdgdesktopportal enabled via IUSE=dbus) "Fix populating selection clipboard with keyboard" QTBUG: https://bugreports.qt.io/browse/QTBUG-59879 See also: https://codereview.qt-project.org/c/qt/qtbase/+/190885 "Make QStyle::proxy() always return the leaf proxy" QTBUG: https://bugreports.qt.io/browse/QTBUG-85556 Revert "QPushButton: fix support of style sheet rule for text alignment" QTBUG: https://bugreports.qt.io/browse/QTBUG-91735 QTBUG: https://bugreports.qt.io/browse/QTBUG-86857 Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-qt')
-rw-r--r--dev-qt/qtwidgets/Manifest1
-rw-r--r--dev-qt/qtwidgets/qtwidgets-5.15.2-r12.ebuild64
2 files changed, 65 insertions, 0 deletions
diff --git a/dev-qt/qtwidgets/Manifest b/dev-qt/qtwidgets/Manifest
index 4b8920365b9d..2487ae322ae8 100644
--- a/dev-qt/qtwidgets/Manifest
+++ b/dev-qt/qtwidgets/Manifest
@@ -1 +1,2 @@
DIST qtbase-5.15.2-a4f9e569.tar.gz 67964648 BLAKE2B 2be7351221c46846ef37308a0238aa4a39369da63fe5c3be5e142ff700c80e125821c06b43c9e4e949bd9f285222a60888303aef956c9b427a9a6c8ee3bc6b1a SHA512 b4be8132a1d7119fd9728f7bf2d72cdd27d2092e7f178a1f15707204f5ffade7ce505c897fd658bb19274bdd6238b2eb16f7fcfedff2567877dc3458b4091388
+DIST qtbase-5.15.2-c9fde86b.tar.gz 67960262 BLAKE2B d1a6a7dac78abce189a753c0a00185fbe03f9de97b226790535af73a9bc009b353fe1edeb754d2098a7beeb7cd1c6e7efb949797658269ef0d0f200f11909820 SHA512 99026537dd4da678bcb04214ebb717907422e373b44fd3b3716798565c330f8d492ec1fc67d936c5125292b30e44f23abe4bf6434b58b9fa76bada3680dfc9f8
diff --git a/dev-qt/qtwidgets/qtwidgets-5.15.2-r12.ebuild b/dev-qt/qtwidgets/qtwidgets-5.15.2-r12.ebuild
new file mode 100644
index 000000000000..1ad9cc0c3aef
--- /dev/null
+++ b/dev-qt/qtwidgets/qtwidgets-5.15.2-r12.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+KDE_ORG_COMMIT=c9fde86b0a2440133bc08f4811b6ca793be47f0a
+QT5_MODULE="qtbase"
+inherit qt5-build
+
+DESCRIPTION="Set of components for creating classic desktop-style UIs for the Qt5 framework"
+
+if [[ ${QT5_BUILD_TYPE} == release ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86"
+fi
+
+# keep IUSE defaults in sync with qtgui
+IUSE="dbus gles2-only gtk +png +X"
+
+REQUIRED_USE="gtk? ( dbus )"
+
+DEPEND="
+ =dev-qt/qtcore-${QT5_PV}*:5=
+ =dev-qt/qtgui-${QT5_PV}*:5=[gles2-only=,png=,X?]
+ dbus? ( =dev-qt/qtdbus-${QT5_PV}* )
+ gtk? (
+ dev-libs/glib:2
+ =dev-qt/qtgui-${QT5_PV}*:5=[dbus]
+ x11-libs/gtk+:3
+ x11-libs/libX11
+ x11-libs/pango
+ )
+"
+RDEPEND="${DEPEND}"
+
+QT5_TARGET_SUBDIRS=(
+ src/tools/uic
+ src/widgets
+ src/plugins/platformthemes
+)
+
+QT5_GENTOO_CONFIG=(
+ dbus:xdgdesktopportal:
+ gtk:gtk3:
+ ::widgets
+ !:no-widgets:
+)
+
+QT5_GENTOO_PRIVATE_CONFIG=(
+ :widgets
+)
+
+src_configure() {
+ local myconf=(
+ -opengl $(usex gles2-only es2 desktop)
+ $(qt_use dbus)
+ $(qt_use gtk)
+ -gui
+ $(qt_use png libpng system)
+ -widgets
+ $(qt_use X xcb)
+ $(usev X '-xcb-xlib -xkbcommon')
+ )
+ qt5-build_src_configure
+}