summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-10-12 20:31:07 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-10-12 21:08:35 +0200
commitdb8a7e36a696bfad012bed676d4bce6bc790a299 (patch)
tree0de08455414d5b45f9fadfb7f34d03bf2e6a774f /dev-ros/clear_costmap_recovery/clear_costmap_recovery-1.17.1.ebuild
parentdev-ros/carrot_planner: Bump to 1.17.1. (diff)
downloadgentoo-db8a7e36a696bfad012bed676d4bce6bc790a299.tar.gz
gentoo-db8a7e36a696bfad012bed676d4bce6bc790a299.tar.bz2
gentoo-db8a7e36a696bfad012bed676d4bce6bc790a299.zip
dev-ros/clear_costmap_recovery: Bump to 1.17.1.
Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/clear_costmap_recovery/clear_costmap_recovery-1.17.1.ebuild')
-rw-r--r--dev-ros/clear_costmap_recovery/clear_costmap_recovery-1.17.1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-ros/clear_costmap_recovery/clear_costmap_recovery-1.17.1.ebuild b/dev-ros/clear_costmap_recovery/clear_costmap_recovery-1.17.1.ebuild
new file mode 100644
index 000000000000..5f505a6c1a2e
--- /dev/null
+++ b/dev-ros/clear_costmap_recovery/clear_costmap_recovery-1.17.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+ROS_REPO_URI="https://github.com/ros-planning/navigation"
+ROS_SUBDIR=${PN}
+KEYWORDS="~amd64 ~arm"
+
+inherit ros-catkin
+
+DESCRIPTION="Recovery behavior that attempts reverting the costmaps to the static map"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ >=dev-ros/costmap_2d-1.16.3
+ dev-cpp/eigen:3
+ dev-ros/nav_core
+ dev-ros/pluginlib
+ dev-ros/roscpp
+ dev-ros/tf2_ros
+
+ dev-libs/boost:=[threads]
+ dev-libs/console_bridge:=
+"
+DEPEND="${RDEPEND}
+ dev-ros/cmake_modules
+ test? ( dev-ros/rostest dev-cpp/gtest )
+"