summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-07-10 17:49:01 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-07-10 18:02:03 +0200
commitdaf252a20a863ad6ece8d7f07987b1977d5cc1ba (patch)
treebc173b33f4f1d93836e8929f5a2fae9fd3f8ced3 /dev-ros/costmap_2d
parentdev-ros/dwa_local_planner: Remove old (diff)
downloadgentoo-daf252a20a863ad6ece8d7f07987b1977d5cc1ba.tar.gz
gentoo-daf252a20a863ad6ece8d7f07987b1977d5cc1ba.tar.bz2
gentoo-daf252a20a863ad6ece8d7f07987b1977d5cc1ba.zip
dev-ros/costmap_2d: bump eapi
Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/costmap_2d')
-rw-r--r--dev-ros/costmap_2d/costmap_2d-1.17.0.ebuild15
-rw-r--r--dev-ros/costmap_2d/costmap_2d-9999.ebuild17
2 files changed, 17 insertions, 15 deletions
diff --git a/dev-ros/costmap_2d/costmap_2d-1.17.0.ebuild b/dev-ros/costmap_2d/costmap_2d-1.17.0.ebuild
index 87474f1cdd7c..d7c0d4caf1c0 100644
--- a/dev-ros/costmap_2d/costmap_2d-1.17.0.ebuild
+++ b/dev-ros/costmap_2d/costmap_2d-1.17.0.ebuild
@@ -1,12 +1,11 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
ROS_REPO_URI="https://github.com/ros-planning/navigation"
ROS_SUBDIR=${PN}
KEYWORDS="~amd64 ~arm"
CATKIN_HAS_MESSAGES=yes
-PYTHON_COMPAT=( python2_7 )
CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/std_msgs dev-ros/geometry_msgs dev-ros/map_msgs"
inherit ros-catkin
@@ -21,16 +20,12 @@ RDEPEND="
dev-ros/dynamic_reconfigure[${PYTHON_USEDEP}]
dev-ros/laser_geometry
dev-ros/message_filters
- dev-ros/nav_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
dev-ros/pluginlib
dev-ros/roscpp
- dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
dev-ros/tf2
dev-ros/tf2_ros
- dev-ros/visualization_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
dev-ros/voxel_grid
- dev-ros/tf2_geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
dev-ros/tf2_sensor_msgs
dev-cpp/eigen:3
@@ -38,10 +33,16 @@ RDEPEND="
dev-libs/tinyxml2:=
"
DEPEND="${RDEPEND}
- dev-ros/cmake_modules
+ dev-ros/nav_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/visualization_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/tf2_geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
test? (
dev-ros/map_server
dev-ros/rosbag
dev-ros/rostest[${PYTHON_USEDEP}]
dev-ros/rosunit
)"
+BDEPEND="
+ dev-ros/cmake_modules
+"
diff --git a/dev-ros/costmap_2d/costmap_2d-9999.ebuild b/dev-ros/costmap_2d/costmap_2d-9999.ebuild
index 4a554602785b..d7c0d4caf1c0 100644
--- a/dev-ros/costmap_2d/costmap_2d-9999.ebuild
+++ b/dev-ros/costmap_2d/costmap_2d-9999.ebuild
@@ -1,12 +1,11 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
ROS_REPO_URI="https://github.com/ros-planning/navigation"
ROS_SUBDIR=${PN}
KEYWORDS="~amd64 ~arm"
CATKIN_HAS_MESSAGES=yes
-PYTHON_COMPAT=( python2_7 )
CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/std_msgs dev-ros/geometry_msgs dev-ros/map_msgs"
inherit ros-catkin
@@ -21,16 +20,12 @@ RDEPEND="
dev-ros/dynamic_reconfigure[${PYTHON_USEDEP}]
dev-ros/laser_geometry
dev-ros/message_filters
- dev-ros/nav_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
dev-ros/pluginlib
dev-ros/roscpp
- dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
dev-ros/tf2
dev-ros/tf2_ros
- dev-ros/visualization_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
dev-ros/voxel_grid
- dev-ros/tf2_geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
dev-ros/tf2_sensor_msgs
dev-cpp/eigen:3
@@ -38,10 +33,16 @@ RDEPEND="
dev-libs/tinyxml2:=
"
DEPEND="${RDEPEND}
- dev-ros/cmake_modules
+ dev-ros/nav_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/visualization_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/tf2_geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
test? (
dev-ros/map_server
dev-ros/rosbag
dev-ros/rostest[${PYTHON_USEDEP}]
dev-ros/rosunit
)"
+BDEPEND="
+ dev-ros/cmake_modules
+"