summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2018-02-15 06:26:46 +0100
committerAlexis Ballier <aballier@gentoo.org>2018-02-15 06:26:46 +0100
commitaf1735b09d3cb56cfc42a356a605121f664384ea (patch)
treeffeb5b7ff9a631ee7209406fd9c6fc8ae8073ab8 /dev-ros/gazebo_ros/gazebo_ros-2.7.4.ebuild
parentdev-ros/gazebo_plugins: Bump to 2.7.4. (diff)
downloadgentoo-af1735b09d3cb56cfc42a356a605121f664384ea.tar.gz
gentoo-af1735b09d3cb56cfc42a356a605121f664384ea.tar.bz2
gentoo-af1735b09d3cb56cfc42a356a605121f664384ea.zip
dev-ros/gazebo_ros: Bump to 2.7.4.
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'dev-ros/gazebo_ros/gazebo_ros-2.7.4.ebuild')
-rw-r--r--dev-ros/gazebo_ros/gazebo_ros-2.7.4.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-ros/gazebo_ros/gazebo_ros-2.7.4.ebuild b/dev-ros/gazebo_ros/gazebo_ros-2.7.4.ebuild
new file mode 100644
index 000000000000..ca217b085352
--- /dev/null
+++ b/dev-ros/gazebo_ros/gazebo_ros-2.7.4.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-simulation/gazebo_ros_pkgs"
+KEYWORDS="~amd64"
+PYTHON_COMPAT=( python2_7 )
+CATKIN_HAS_MESSAGES=yes
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="ROS plugins that offer message and service publishers for interfacing with gazebo"
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/gazebo_dev
+ dev-libs/tinyxml
+ sci-electronics/gazebo:=
+ dev-libs/protobuf:=
+ dev-ros/gazebo_plugins[${PYTHON_USEDEP}]
+ dev-ros/roslib[${PYTHON_USEDEP}]
+ dev-ros/roscpp
+ dev-ros/tf[${PYTHON_USEDEP}]
+ dev-ros/dynamic_reconfigure
+ dev-libs/libxml2
+ dev-libs/boost:=[threads]
+ dev-ros/gazebo_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/std_msgs
+ dev-ros/geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP},${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/rosgraph_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/std_srvs[${CATKIN_MESSAGES_CXX_USEDEP},${CATKIN_MESSAGES_PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"