summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2021-01-05 20:46:20 +0100
committerAlexis Ballier <aballier@gentoo.org>2021-01-05 21:02:57 +0100
commit3c004edf24fc8dffc2bfe83f310e96b7aa020dde (patch)
treedc94efb628442c7bc1f7fc52fc8a4009049941f9 /dev-ros/hector_geotiff/hector_geotiff-0.5.0.ebuild
parentdev-ros/hector_trajectory_server: Bump to 0.5.0. (diff)
downloadgentoo-3c004edf24fc8dffc2bfe83f310e96b7aa020dde.tar.gz
gentoo-3c004edf24fc8dffc2bfe83f310e96b7aa020dde.tar.bz2
gentoo-3c004edf24fc8dffc2bfe83f310e96b7aa020dde.zip
dev-ros/hector_geotiff: Bump to 0.5.0.
Package-Manager: Portage-3.0.8, Repoman-3.0.2 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/hector_geotiff/hector_geotiff-0.5.0.ebuild')
-rw-r--r--dev-ros/hector_geotiff/hector_geotiff-0.5.0.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-ros/hector_geotiff/hector_geotiff-0.5.0.ebuild b/dev-ros/hector_geotiff/hector_geotiff-0.5.0.ebuild
new file mode 100644
index 000000000000..48e9eac5ce89
--- /dev/null
+++ b/dev-ros/hector_geotiff/hector_geotiff-0.5.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+ROS_REPO_URI="https://github.com/tu-darmstadt-ros-pkg/hector_slam"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Saves occupancy grid map, robot trajectory and object data to GeoTiff images"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/hector_map_tools
+ dev-ros/pluginlib
+ dev-libs/tinyxml2:=
+ dev-libs/console_bridge:=
+ dev-ros/roscpp
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ dev-libs/boost:=
+"
+DEPEND="${RDEPEND}
+ dev-ros/hector_nav_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/nav_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/std_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-cpp/eigen:3"
+
+PATCHES=( "${FILESDIR}/qt5.patch" )