summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-07-08 16:19:15 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-07-08 19:29:26 +0200
commit3caddeba12aac36a7f581669ef23fa3fcb6e0caa (patch)
tree6051cb6f063a4e71cf802d5f30dc238d77cedd7b /dev-ros/joint_state_publisher/joint_state_publisher-1.15.0.ebuild
parentmedia-radio/xlog: Version bump (diff)
downloadgentoo-3caddeba12aac36a7f581669ef23fa3fcb6e0caa.tar.gz
gentoo-3caddeba12aac36a7f581669ef23fa3fcb6e0caa.tar.bz2
gentoo-3caddeba12aac36a7f581669ef23fa3fcb6e0caa.zip
dev-ros/joint_state_publisher: bump to 1.15.0
Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/joint_state_publisher/joint_state_publisher-1.15.0.ebuild')
-rw-r--r--dev-ros/joint_state_publisher/joint_state_publisher-1.15.0.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-ros/joint_state_publisher/joint_state_publisher-1.15.0.ebuild b/dev-ros/joint_state_publisher/joint_state_publisher-1.15.0.ebuild
new file mode 100644
index 000000000000..fc248b3b5af7
--- /dev/null
+++ b/dev-ros/joint_state_publisher/joint_state_publisher-1.15.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+ROS_REPO_URI="https://github.com/ros/joint_state_publisher"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Tool for setting and publishing joint state values for a given URDF"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+"
+DEPEND="${DEPEND}
+ test? ( dev-ros/rostest[${PYTHON_USEDEP}] )"