summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2018-03-25 15:32:30 +0200
committerAlexis Ballier <aballier@gentoo.org>2018-03-25 15:48:45 +0200
commite4837739975f301f6f76efa7b88cb3a261435611 (patch)
treea7b0a19103f7794861c9a36963ac43e7f2403eb0 /dev-ros/nav_core/nav_core-1.15.2.ebuild
parentdev-ros/move_slow_and_clear: Bump to 1.15.2. (diff)
downloadgentoo-e4837739975f301f6f76efa7b88cb3a261435611.tar.gz
gentoo-e4837739975f301f6f76efa7b88cb3a261435611.tar.bz2
gentoo-e4837739975f301f6f76efa7b88cb3a261435611.zip
dev-ros/nav_core: Bump to 1.15.2.
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'dev-ros/nav_core/nav_core-1.15.2.ebuild')
-rw-r--r--dev-ros/nav_core/nav_core-1.15.2.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-ros/nav_core/nav_core-1.15.2.ebuild b/dev-ros/nav_core/nav_core-1.15.2.ebuild
new file mode 100644
index 000000000000..3461f7166e3d
--- /dev/null
+++ b/dev-ros/nav_core/nav_core-1.15.2.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-planning/navigation"
+ROS_SUBDIR=${PN}
+KEYWORDS="~amd64 ~arm"
+
+inherit ros-catkin
+
+DESCRIPTION="Common interfaces for navigation specific robot actions"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/std_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/tf
+ dev-ros/costmap_2d
+"
+DEPEND="${RDEPEND}"