summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-10-11 17:12:54 +0200
committerAlexis Ballier <aballier@gentoo.org>2015-10-11 17:12:54 +0200
commit4bb80a001a41f3d24a4d53eccbf588a180c8a3ba (patch)
tree827685310cd452c59f74fa007f9a2d386b1cc2fe /dev-ros/rosauth/rosauth-0.1.7.ebuild
parentdev-ros/rosapi: Initial import. Ebuild by me. (diff)
downloadgentoo-4bb80a001a41f3d24a4d53eccbf588a180c8a3ba.tar.gz
gentoo-4bb80a001a41f3d24a4d53eccbf588a180c8a3ba.tar.bz2
gentoo-4bb80a001a41f3d24a4d53eccbf588a180c8a3ba.zip
dev-ros/rosauth: Initial import. Ebuild by me.
Package-Manager: portage-2.2.23
Diffstat (limited to 'dev-ros/rosauth/rosauth-0.1.7.ebuild')
-rw-r--r--dev-ros/rosauth/rosauth-0.1.7.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-ros/rosauth/rosauth-0.1.7.ebuild b/dev-ros/rosauth/rosauth-0.1.7.ebuild
new file mode 100644
index 000000000000..ff0731f53943
--- /dev/null
+++ b/dev-ros/rosauth/rosauth-0.1.7.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+CATKIN_HAS_MESSAGES=yes
+ROS_REPO_URI="https://github.com/WPI-RAIL/rosauth"
+KEYWORDS="~amd64"
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="Server Side tools for Authorization and Authentication of ROS Clients"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/roscpp
+ dev-ros/rostest[${PYTHON_USEDEP}]
+ dev-libs/openssl:0="
+DEPEND="${RDEPEND}
+ test? ( dev-ros/rostest[${PYTHON_USEDEP}] )"