summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-09-22 14:54:38 +0200
committerAlexis Ballier <aballier@gentoo.org>2015-09-22 16:36:22 +0200
commit9573d01e4899900f7608ffc6f67da1aea0e8754d (patch)
tree442a68b1929e88809190c39d52ef27198347576c /dev-ros/rosgraph/rosgraph-9999.ebuild
parentdev-ros/std_srvs: Initial import. Ebuild by me. (diff)
downloadgentoo-9573d01e4899900f7608ffc6f67da1aea0e8754d.tar.gz
gentoo-9573d01e4899900f7608ffc6f67da1aea0e8754d.tar.bz2
gentoo-9573d01e4899900f7608ffc6f67da1aea0e8754d.zip
dev-ros/rosgraph: Initial import. Ebuild by me.
Package-Manager: portage-2.2.21
Diffstat (limited to 'dev-ros/rosgraph/rosgraph-9999.ebuild')
-rw-r--r--dev-ros/rosgraph/rosgraph-9999.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-ros/rosgraph/rosgraph-9999.ebuild b/dev-ros/rosgraph/rosgraph-9999.ebuild
new file mode 100644
index 000000000000..b4d40e484bf3
--- /dev/null
+++ b/dev-ros/rosgraph/rosgraph-9999.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/ros_comm"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+ROS_SUBDIR=tools/${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Prints information about the ROS Computation Graph"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-python/netifaces[${PYTHON_USEDEP}]
+ dev-python/rospkg[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? ( dev-python/mock[${PYTHON_USEDEP}] dev-python/nose[${PYTHON_USEDEP}] )"