summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-08-11 15:21:23 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-08-11 15:23:13 +0200
commit846ed0ec182233455a294e451c3cb66469a58e17 (patch)
treeb86bba92a7f81bef4f3f54e0310c751e41ee26c8 /dev-ros/rospy_tutorials/rospy_tutorials-0.10.2.ebuild
parentdev-ros/roscpp_tutorials: Bump to 0.10.2. (diff)
downloadgentoo-846ed0ec182233455a294e451c3cb66469a58e17.tar.gz
gentoo-846ed0ec182233455a294e451c3cb66469a58e17.tar.bz2
gentoo-846ed0ec182233455a294e451c3cb66469a58e17.zip
dev-ros/rospy_tutorials: Bump to 0.10.2.
Package-Manager: Portage-3.0.2, Repoman-2.3.23 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/rospy_tutorials/rospy_tutorials-0.10.2.ebuild')
-rw-r--r--dev-ros/rospy_tutorials/rospy_tutorials-0.10.2.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-ros/rospy_tutorials/rospy_tutorials-0.10.2.ebuild b/dev-ros/rospy_tutorials/rospy_tutorials-0.10.2.ebuild
new file mode 100644
index 000000000000..ecde7b0dc1db
--- /dev/null
+++ b/dev-ros/rospy_tutorials/rospy_tutorials-0.10.2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+ROS_REPO_URI="https://github.com/ros/ros_tutorials"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+CATKIN_HAS_MESSAGES=yes
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/std_msgs"
+
+inherit ros-catkin
+
+DESCRIPTION="Attempts to show the features of ROS step-by-step"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/rospy[${PYTHON_SINGLE_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ test? (
+ dev-ros/rostest[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/roscpp_tutorials
+ )"
+
+src_test() {
+ export ROS_PACKAGE_PATH="${S}:${ROS_PACKAGE_PATH}"
+ ros-catkin_src_test
+}