summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-10-20 11:55:26 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-10-20 14:43:57 +0200
commitba2445669f5c3c554b7b5bed419c3c44073c990d (patch)
tree6ca4b70bf03ca7da2e6ac4e7917e7f058f86ff0c /dev-ros/rostopic/rostopic-1.15.9.ebuild
parentdev-ros/rostest: Bump to 1.15.9. (diff)
downloadgentoo-ba2445669f5c3c554b7b5bed419c3c44073c990d.tar.gz
gentoo-ba2445669f5c3c554b7b5bed419c3c44073c990d.tar.bz2
gentoo-ba2445669f5c3c554b7b5bed419c3c44073c990d.zip
dev-ros/rostopic: Bump to 1.15.9.
Package-Manager: Portage-3.0.8, Repoman-3.0.2 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/rostopic/rostopic-1.15.9.ebuild')
-rw-r--r--dev-ros/rostopic/rostopic-1.15.9.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-ros/rostopic/rostopic-1.15.9.ebuild b/dev-ros/rostopic/rostopic-1.15.9.ebuild
new file mode 100644
index 000000000000..c436e4f953a2
--- /dev/null
+++ b/dev-ros/rostopic/rostopic-1.15.9.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ROS_REPO_URI="https://github.com/ros/ros_comm"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=tools/${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Command-line tool for displaying debug information about ROS Topics"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/rosbag[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/rospy[${PYTHON_SINGLE_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ test? (
+ dev-ros/rostest[${PYTHON_SINGLE_USEDEP}]
+ $(python_gen_cond_dep "dev-python/nose[\${PYTHON_USEDEP}]")
+ )
+"
+
+src_test() {
+ export ROS_PACKAGE_PATH="${S}:${ROS_PACKAGE_PATH}"
+ ros-catkin_src_test
+}