summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-08-31 08:08:18 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-08-31 11:10:17 +0200
commit4445793c6d3543fa67c3c84d6b9988fd7f422ded (patch)
treedfaf6a52cfa3d8b49d046c1f849659bde014a63c /dev-ros/test_bond/test_bond-1.8.6.ebuild
parentdev-ros/smclib: Bump to 1.8.6. (diff)
downloadgentoo-4445793c6d3543fa67c3c84d6b9988fd7f422ded.tar.gz
gentoo-4445793c6d3543fa67c3c84d6b9988fd7f422ded.tar.bz2
gentoo-4445793c6d3543fa67c3c84d6b9988fd7f422ded.zip
dev-ros/test_bond: Bump to 1.8.6.
Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/test_bond/test_bond-1.8.6.ebuild')
-rw-r--r--dev-ros/test_bond/test_bond-1.8.6.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-ros/test_bond/test_bond-1.8.6.ebuild b/dev-ros/test_bond/test_bond-1.8.6.ebuild
new file mode 100644
index 000000000000..cd85cdd267fc
--- /dev/null
+++ b/dev-ros/test_bond/test_bond-1.8.6.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+ROS_REPO_URI="https://github.com/ros/bond_core"
+KEYWORDS="~amd64 ~arm"
+CATKIN_HAS_MESSAGES=yes
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Tests for bond, bondpy and bondcpp"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/bondcpp
+ dev-ros/bondpy[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/rostest[${PYTHON_SINGLE_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ test? ( dev-cpp/gtest )
+"
+
+src_test() {
+ export ROS_PACKAGE_PATH="${S}:${ROS_PACKAGE_PATH}"
+ ros-catkin_src_test
+}