summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-09-03 18:41:11 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-09-03 18:48:03 +0200
commit656cfc1778f3d3f60c928cfdaa848d01426665a9 (patch)
tree86ff1ab2ae813bc88a4c2813176877f4ab92fbe0 /dev-ros/test_tf2/test_tf2-0.7.5.ebuild
parentsys-kernel/bliss-initramfs: bumping to 9.2.0 (diff)
downloadgentoo-656cfc1778f3d3f60c928cfdaa848d01426665a9.tar.gz
gentoo-656cfc1778f3d3f60c928cfdaa848d01426665a9.tar.bz2
gentoo-656cfc1778f3d3f60c928cfdaa848d01426665a9.zip
dev-ros/test_tf2: Bump to 0.7.5.
Package-Manager: Portage-3.0.5, Repoman-3.0.1 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/test_tf2/test_tf2-0.7.5.ebuild')
-rw-r--r--dev-ros/test_tf2/test_tf2-0.7.5.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-ros/test_tf2/test_tf2-0.7.5.ebuild b/dev-ros/test_tf2/test_tf2-0.7.5.ebuild
new file mode 100644
index 000000000000..24179b340482
--- /dev/null
+++ b/dev-ros/test_tf2/test_tf2-0.7.5.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+ROS_REPO_URI="https://github.com/ros/geometry2"
+KEYWORDS="~amd64"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="TF2 unit tests"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND=""
+DEPEND="
+ dev-ros/rosconsole
+ dev-ros/roscpp
+ dev-ros/rostest[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/tf
+ dev-ros/tf2
+ dev-ros/tf2_bullet
+ dev-ros/tf2_ros[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/tf2_geometry_msgs[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/tf2_kdl[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/tf2_msgs
+ dev-ros/rosbash
+ sci-libs/orocos_kdl
+ $(python_gen_cond_dep "dev-python/python_orocos_kdl[\${PYTHON_USEDEP}]")
+ dev-libs/boost:=[threads]
+ dev-cpp/gtest
+"
+
+mycatkincmakeargs=( "-DCATKIN_ENABLE_TESTING=ON" )