summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-07-15 18:26:25 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-07-16 14:17:00 +0200
commitb9cb42ece43f074122b7db868e8febc1eeb65441 (patch)
tree26f5d640f4cfcc4973a624665f8451396c233bde /dev-ros/tf2_ros/tf2_ros-0.5.16.ebuild
parentdev-ros/tf2_py: Bump to 0.5.16. (diff)
downloadgentoo-b9cb42ece43f074122b7db868e8febc1eeb65441.tar.gz
gentoo-b9cb42ece43f074122b7db868e8febc1eeb65441.tar.bz2
gentoo-b9cb42ece43f074122b7db868e8febc1eeb65441.zip
dev-ros/tf2_ros: Bump to 0.5.16.
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'dev-ros/tf2_ros/tf2_ros-0.5.16.ebuild')
-rw-r--r--dev-ros/tf2_ros/tf2_ros-0.5.16.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-ros/tf2_ros/tf2_ros-0.5.16.ebuild b/dev-ros/tf2_ros/tf2_ros-0.5.16.ebuild
new file mode 100644
index 000000000000..00234a1ad22c
--- /dev/null
+++ b/dev-ros/tf2_ros/tf2_ros-0.5.16.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros/geometry2"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="ROS bindings for the tf2 library, for both Python and C++"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/actionlib[${PYTHON_USEDEP}]
+ dev-ros/message_filters
+ dev-ros/roscpp
+ dev-ros/rosgraph
+ dev-libs/boost:=[threads]
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-ros/tf2
+ dev-ros/tf2_py[${PYTHON_USEDEP}]
+ dev-ros/actionlib_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/geometry_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP},${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/tf2_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP},${CATKIN_MESSAGES_CXX_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ test? ( dev-ros/rostest[${PYTHON_USEDEP}] )"